Conditional rendering on field editor with column set not working.

If field editor has sections with column sets and conditional rendering on section based on picklist value of row, rendering works for first time but doesn’t work after on.

xml of sample page.

*****************************************************************************


































































































































































&nbsp

Hello Pawan,

Thank you for providing this example as a starting point. Which version of Skuid are you working with? I was not able to reproduce any rendering issues with your example XML either in Brooklyn (Iteration 1.1) or Rockaway (Iteration 10). What I saw was that the two sections that are conditionally rendered based on the priority being high or low would show and hide each time I changed the priority. They also were rendered correctly when I would reload the page. 

Mark

Hi Mark,


Thank you for quick reply. I am with skuid version 9.3 in one org and version 8.15.15 in other org.
The issue is in both place.

Steps to reproduce:

  1. Add or edit from table action
  2. Change priority to low or high, rendering works for first choice of each
  3. Again change priority low to high or high to low
  4. Again change priority low to high or high to low
  5. Again change priority low to high or high to low

Here, browser console gives error as in attached with my question and it doesn’t  render field editor sections as expected.