Cloned page: All field updates not carrying over to new record

I have a cloned quote page. Which the detail and line items are cloned to a new quote. When I push save a few fields are updated, the record is saved and then you are redirected to the detail page. The problem is there is one field that gets updated properly in the cloned page but the value is not showing in the detail page. 

The field that I am having a problem with is “Quote Valid For” it is a number field and it needs to default to 30. Since this is not a “new page” I can not just set a condition. So I update the field row in the “save” button. The value does not carry over to the detail record. I tried creating a workflow that whenever a new quote is created that field will default to 30. That did not work either for this cloned page.

Has anyone else run into this issue and found a solution?

Thanks!

Sounds like there is something else setting the value after the save outside Skuid. A workflow, process builder, trigger, etc.

What happens when you create a brand new quote and set the “Quote Valid For” field? Is the value you set kept?

That is what I thought as well but I could not find anything. I will check again though. When a new quote is created there is a condition set for the value to be 30. 

Ok. Temporarily remove the condition to see what happens. Actually, you could leave the condition and alter the value. The condition is only going to default the value to 30. It will still save with the edited value.

It defaults to ‘30’, the field has a default value of 30. I see that all of this points to the fact that something is changing the value :-). What seems to be happening when I clone a record it is that it keeps the original value from the quote being cloned from. I have tried overriding the field, I have tried not including the field. So far the value still carries over. 

You’ve peaked my curiosity for sure. Lemeno if you’re up for a screen share.

Absolutely! I have been banging my head against this issue for a while. Are you free at 1:30 EST?

Sure. just emailed you.

Thanks just emailed you back.

I think I have this working now. I changed the “Clone Model Data” on the main model. Originally I had it set to “Yes” I changed it to "Yes, if ‘clone’ parameter is present in URL. I tested on multiple quotes and the Valid for date stuck.

Ah!!! You took my fun away. It was going to be a hunt. :wink:

Fear not my friend I am sure I will have a new hunt for us!