Changing Model Name, page include issue

Hi Guys,

Experiencing a weird issue i have never encountered before

I have 2 pages. Lets call the 1st one: Page A  and the Second one Page B

Page A has a button to call with a popup action to show Page B in a page include

All worked well until…

On Page B i changed the Model Name from Sub1  to SubApp  (that did not change all reference to Sub1 Model, so in XML i tried to change to the proper model)

To make sure I did not do an error in XML, i changed the reference to Old Model name on 1 UI field only from this value 


to this value 


When I preview Page B by itself all works well, 

When Page B is called From page A via Page Include nothing renders, and looking at console here’s error

“1. There was a problem rendering a component of type skuidpage: Cannot read property ‘displaytype’ of undefined”

Any ideas? 

I’m an older version of skuid: 10.0.23


Bumped by error

Hey Dave, interesting. We definitely do recommend that you upgrade to a supported version of Skuid, which you can do on Install the latest 12.2.x or 11.2.x in a Sandbox and see if the error persists.*

Additionally, here are a few troubleshooting suggestions.

  1. So "SubApp" is the new model name; are there any models in Page A called SubApp?
  2. Is this Ui only field on Page B or Page A?  I'm guessing it's on a different model and not "SubApp?"
  3. Looking through previous community posts (this one and this one) it seems like you may be getting this error because the Ui field is trying to update itself before the SubApp model has been loaded. 
  4. Try, rather than using a UI only field, using the merge syntax {{$}} in a template component or a template field. This way all the data should have time to load, since models are loaded before components.
  5. Double check in the XML that you have removed/changed any mentions of the Sub1 model.
*Note on upgrading: As a reminder, Salesforce does NOT allow reverting back to prior versions of managed packages. Skuid always recommends installing new versions in a non-business critical sandbox environment to test all mission critical functionality before installing into a production environment. We also recommend that you update out of date themes after you upgrade. Please let us know if you continue to encounter any problems with this issue after upgrading.


Weirdly enough, I fixed it by changing all Model names in that page and like magic it worked again…

Not sure how but in case it ever helps anyone…

So interesting!  When you change a model’s name, Skuid does run some logic to update the model name in other areas of the page (conditions, components, etc.) so perhaps that helped reset things.

NB: The more recent your version of Skuid, the more places that Skuid will automatically update your model names if you change them. However sometimes things fall through the cracks. If you are changing the model name, we recommend you open the View/Edit XML and use “Find and Replace” in your browser to find and replace any references to the old model name with the new model name to make sure nothing gets overlooked.