Changes to page design not saving

I am making simple changes to a page in the page builder.  Sometimes the Save button does not even activate.  Sometimes it does.  When it does, I click save, but then when I attempt to preview the page, my changes are not there or not working.  

For example I just re-arranged my filter buttons.  The Save button didn’t even activate.  When I preview… nothing changed.

Example#2.  I added a multi-select filter button. This time the Save button activated.  I clicked it.  My filter button showed up in the Preview, but it doesn’t work.  This is simple multi-select using the existing values on the field in the system.

Hi Stephen,

In a scenario like this, I’ve found that you can get the save button re-enabled by making a change to your page and then undoing it, to force the editor to reevaluate the page’s XML. For example, add another field to a model, then immediately remove it.

You can also check the page’s actual contents and preserve your work with the “View/Edit XML” link in the bottom right corner. The XML can be copied and pasted into a new Skuid page, or your Notepad of choice. 

To understand more about what’s happening: which version of Skuid are you working with? When did you first notice this behavior? 


I am in a sandbox environment using Spring 14 version 2.2.

How do I get the latest version loaded into my sandbox?

I found the links and installed the latest version of Brooklyn in my sandbox.  Although many features changed (confirming the install was successful) I am still having this problem with my filter buttons.  I move them around on my page design and save.  Then I preview and my changes are not showing.  The buttons are still arranged the way they were before.  I even tried adding a field to my table and saving.  That didn’t work either.

I tried with both table filters and the filter set component, and I wasn’t able to reproduce this issue in version 9.3.0 or 9.3.1. Do you find similar behavior when making other changes, or is it specific to your filter placement?


Seems to only occur with filter placement

Which version of Skuid do you have installed? 

I just upgraded using the most recent version of Brooklyn.  How do I find/see the version numbers though?

If you’re using Chrome, while on a Skuid page you can bring up the console (cmd-opt-j on Mac, ctrl-shift-j on Windows) and run the skuid.version command. You can also take a look at your Installed Packages via Salesforce Setup to see Skuid’s version. 

Installed packages shows Version 2.2

In that case, it sounds like you’ve still got an older version installed, and the filter order issue has been resolved in a more recent version. You can see the chronology of the releases on our releases page, and should be able to use the link button on the left to install Brooklyn Iteration 2 from there. 

  • As a reminder, Salesforce does not allow reverting back to prior versions of managed packages. Skuid always recommends installing new versions in a non-business critical sandbox environment to test all mission critical functionality before installing into a production environment. We also recommend that you update out of date themes when you upgrade.

I hope that helps!

I already installed Brooklyn Iteration 2 this morning.

I just installed it again and received the successful install email.  However it looks like the install did not work.  My version still shows 2.2.  What is happening? 

I just confirmed that I am actually on 9.3.1

Mark I received your note about having two versions installed.  It appears that is the case.  The first one I have is called “Skuid for Sales” and shows version 2.2.  The second is just called “Skuid” and shows version 9.3.1.  I need assurance that uninstalling “Skuid for Sales” will not cause any problems or result in a loss of pages.  

By the way I am not having these issues in our production instance.  We only have the Skuid package 9.3.1 installed there. 


I’ve reached out for this clarification and will get back to you as soon as I have an answer. 

- Mark DeSimone

Stephen, the “Skuid for Sales” package is actually a separate managed package, not the same as Skuid itself, and shouldn’t be related to any of the issues you’re experiencing. So, uninstalling it should not be necessary.

Regarding the filter and saving issues above, I’ve tried to reproduce them in the same version as you’ve got on a simple test page using standard Salesforce objects and fields, but didn’t encounter any trouble saving or reordering them. Do you perhaps have code in your page that might be affecting or overriding the order of the filters? It might also be worth trying to re-order them in the XML editor, as a test. 


I am still experiencing this issue with saving changes to the order of my filter buttons.  I am now seeing the same issue in my production instance.  I open the page builder and re-arrange my filter buttons and the save button does not activate.

Editing another field does activate the save button but clicking it does not seem to save the changes when you preview the page.  They look correct in the page builder but the page preview shows them in a different order entirely.  So what I see on the page builder does not match the page preview.

Is this something that happens with any set of filters, on any page you’re editing? Would you be able to build a very simple XML page with just a couple basic Salesforce objects and fields, to see if the filters misbehave? If so, please post the XML here so we can try to reproduce the issue.