Cant select OData table as source on SKUID Platform

I set up an OData Datasource. And when I create a model and Select OData it sees the Odata source and even sees the table I created. But I can’t seem to select the table that is listed.

Here is a screenshot. It shows up but clicking on the table listing does not do anything like populating the field.

Is that a bug or am I missing something in my configuration that is keeping me from selecting the options listed?


Some additional information. I tried this with a sample OData source to see if changing that might fix the issue and still seeing the same problem. If anyone wants to quickly re-create. Go into Skuid Platform, configure a new Datasource using

Then create a new page and model. Select the OData source type and the Northwind data source and you will have a number of items to select from under the External Object Name but it won’t be possible to select an item.

If anyone has an OData source set up correctly can you please share your XML with me so I can manually create the data source while waiting for a UI fix.

Hi Joseph, do you see any javascript errors in your javascript console when you try to click on the object name?

I fired up the javascript console and I am seeing an error when I click on the entry. Here is a screenshot.

Hi Joseph, I’m able to reproduce this issue on my Skuid platform site as well with the Northwinds data source. I talked to our engineers responsible for OData and a patch has already been developed for this issue, but it has not been pushed to yet. I believe this fix will be pushed in the next few days.

Thank you Ben. Quick follow up question. Are the most recent versions of SKUID shown on apply to both the Installed Application on Salesforce and Skuid Platform or do I need to go somewhere different to see the current version and release notes for Skuid Platform?

Joseph, we are working on adjusting the Skuid Releases page to differentiate between Skuid-on-Salesforce and Skuid Platform releases. The big difference between Skuid Platform and Skuid-on-Salesforce is that Skuid Platform is always on the “latest” version, there is nothing you have to do to upgrade.

We will update this post when this issue is resolved in Skuid Platform, thanks for your patience!

Thank you for bringing this to our attention. This bug has been fixed in the platform and should automatically work for you now. Thank you for your patience.

Thank you Stephen, to confirm I am able to connect successfully to the OData source in platform and see the data. Excellent!

I did notice (and this is probably a separate post) that the latest version of SKUID on Salesforce 9.5.1 does not seem to have an update available on Salesforce and exhibits the same problem as the Platform used to have.

Is the Platform build based on the 8.x releases or the 9.x releases?

Also is this something you anticipate having patched in the near future in 9.x for SF?

Platform is its own separate entity entirely. You won’t have to worry about updating or version. The updates are automatic and immediate.

The correction on Skuid-on-Salesforce will eventually come out, but is dealt with separately.

Stephen - When is the fix for Skuid-on-Salesforce coming out? Running into the same problem and am in urgent need of a fix for the same. Thanks!

Hi, I would like to second this. I have just started to play around with Skuid…connecting to an OData source was the first thing I wanted to do, and  i think I’m affected by this bug.

Check your current version of SKUID in the Installed Packages in Salesforce. I tried with 9.5.1 and it didn’t work and then today upgraded to 9.5.4 and the bug is gone and everything is working as expected.

Thanks for the help…I have just upgraded to 9.5.4 and still running into the same issue.  I think it’s a bit different than what has been described by others. So, I’m including a screenshot. 

Andy, would you mind posting a screenshot of any errors you see in the Chrome/Firefox/IE console when you click the down arrow? 

@Andy Go to “Skuid Settings”, find your Data Source, and click the pencil to edit it inline, then check / enable the “Use Apex Proxy” checkbox.

This is checked by default, and in general you should always leave this box checked. Most Data Sources don’t let you connect to them without going through a proxy.