can't get all events to show in calendar for standard user unless "View All" system permission is gr

This is more of a salesforce issue I think, but I though maybe someone here would have a solution for this.

Here’s the scenario.

  • User is not a sys admin
  • User does not have “View All” system permission
Events for “AssignedTo” other users that are not related via the whoid or whatid, thereby not “Controlled by Parent”, can not be an event shown in the calendar.

Pat…I’m not sure of your use case, but you may want to look at ‘Sharing Settings’ (Setup->Security Controls->Sharing Settings).  You can give groups of users access to each others records.  This will allow them to see Tasks/Events on a calendar.  Do you want them to ‘only’ see the Task/Event without seeing the Parent?  If so, you’ll want to consider a custom object that mirrors Task/Event.  You could display the custom object separately without providing access to the ‘Parent’.

I have the Sharing Settings set for them based the only options for “Activities” are Private and Controlled by Parent. So setting them to Controlled by Parent at least can expose those in which have a parent that is Public, assuming they have access to the Parent object in the first place.

What’s left are Activities that don’t have a Parent. These seem to be left out in the ability to make Public and/or set a sharing rule. There isn’t even an option to set the View All on the Event or Task objects. Seems Salesforce decided to make it impossible to Share “orphaned” Events without resorting to Apex and create a mirror object for Events.

Dang Salesforce.  

Might you be able to create a dummy parent that is the default for new activity records  (maybe with the label “none”) and make this parent “public”.  Then maybe a data cleansing exercize (which Skuid is really good for)  to populate that dummy record to all orphaned activities… 

Ack!!! Fugly! hehehehe … but it would work.