Cannot view icons in row action or buttons in IE11 when using a theme other than Classic

I am working with an organization whose standard browser is IE11. The organization’s IT department deploys a ‘configured’ version of IE11. They currently have Skuid Superbank in production (version 6.8.20).

We have a problem where if we use a theme other than Classic, we do not see the icons for the row action or in any button that we add. Please see the attached screen shot.

Does Skuid have recommended settings for IE? How do we troubleshoot this issue?

Bill do you know if the “Serve Static Resources from Visualforce Domain” Critical Update is enable for this org? Disabling it may fix this issue.

Ben…Thanks for the quick reply.  We had the “Serve Static Resources from Visualforce Domain” Critical Update" activated.  I de-activated it, but I am still seeing the issue (no icons).  Is there something else we can look at?

Go to your themes page - if you see an “Update themes” button at the top of the list, push it and then “Save”   We’ve seen this fix this error. 

@Rob…I tried this in our Sandbox and it did not work.  Also, our Production org. is running Superbank.  There is no provision to update the theme.  Are there other settings we can try?  Can we update the theme manually?

Could we take a look at this issue?  Grant us login rights and send an email to with the Org ID and the Skuid page where this is happening. 


Rob…access granted and email sent.  Thanks!

Bill,  when I try your page in my IE11 environment it works.  Somehow your configured version of IE is preventing the Font Awesome resource from being loaded. 

Could you send us a screenshot of the network tab of the browser console (in the F12 developer tools)  Hopefully it will show some resource that is showing an error.  

Rob…Here you go.

We are not seeing any errors there…

Can you scroll through the network tab and see if you see a 404 error?  Maybe refresh the page after the network tab is open? 

Do you know if your configured browser is running in a compatibility mode? If so with what back version of IE? 


Thanks for the back and forth on this. I am in agreement that we have a ‘configuration setting’ in IE11 that is causing the issue. Like you, I am able to view the icons in a ‘default’ setup of IE11. I searched through the network tab and I do not see any 404 errors (except for one related to a Salesforce image (logo180.png). This error is always present). I have attached the network log showing the Skuid resources loading.

Do you have any suggestions for how to proceed? Any settings to focus on? The company’s IT team is willing to make changes to the configuration of IE11. I need to get them some changes to make.



Hey Bill, Rob asked me to look at this. I can’t immediately identify the issue, but perhaps I can start getting us moving in the right direction.

A little background on the icons. The actually iconography of Skuid icons in all themes but classic are just font awesome icons. This probably not a big surprise. The behavior that your are describing is likely symptomatic of a the font awesome font file not being loaded in by the browser. That being said, the item we would want to find in the network tab is a file labeled “fontawesome-webfont.eot” item. If it’s not there, then that means the font isn’t actually being loaded, and you get no icons.

Now, if the fontawesome font file is not being loaded, then I can only speculate as to why it wouldn’t be. I do know that some browsers will not load a resource (in this case a font) unless it sees evidence that it is needed in the page. This is an optimization technique targeted and reducing needless bandwidth usage. Perhaps your configuration of IE has some sort of setting pertaining to optimization in this realm?

That would be my first area of inquiry, but I don’t want to go any further with speculative solutions until we can confirm that the font file is not being loaded. At that point I might have an idea or two for workarounds.

Rob…Thanks for the referral.

Andrew…Thanks for looking at this. I ran the network trace in IE11 and downloaded the results as an XML file. I think that the FontAwesome ‘fonts’ are getting loaded. Here is the first response that I find when searching for ‘fontawesome’. It looks like it is getting a ‘200’ status. See the screenshot below.