Cannot select field for filter

I’m trying to set up a filter on a model field, but am running into a strange issue where I cannot select a field to filter on. I’ve attached two screenshots of what I’m seeing when I try to select a filter. Has anyone run into something similar and know how to remedy the issue?

Screenshot 1: What I see when I click the Field selector in the Filters tab of the model field
Screenshot 2: What I see when I close the popup in screenshot 1. Selecting one of the options here has zero effect.

Can we get a bump on this? Either we’re doing something very wrong, or this looks like a serious bug that’s keeping us from doing lookup filters.


Kathryn and Dylan,

I was able to reproduce the issue Kathryn is referring to, except I first saw the empty field selection popup with “Contact,Lead” in the header, and when I closed this popup, I saw the popup where you can select a related object (“Contact” or “Lead”) from the dropdown. I’m assuming these screenshots just got uploaded in the wrong order?

Are you working with the WhoId field on the Task object? Because the WhoId field is polymorphic (meaning it can point to either Contact or Lead), it is necessary for you to pick one of these objects before picking a field to filter on. However, it looks like Skuid is showing the 2 popups (related object selection and field selection) in the wrong order. You should be seeing the related object dropdown first. After clicking the field selector, if you drag the empty field selection popup out of the way you should be able to see the related object popup, select an object from the dropdown, and click “Go”:

You should then see a list of fields show up in the field selection popup, and you can pick a field to filter on:

I should also note that, if you want to add separate lookup filters for separate related objects, you should be able to do so, and the relevant lookup filters will be applied for that related object (for example, a filter on AccountId for the Contact and Company for the Lead). I hope this allows you to finish creating your lookup filter. However, this should be fixed in Skuid so the popups open in the right order. Good find! I will report it as a bug to our dev team.

Hey Emily,

That fixed it - thanks!

If you have the possibility to improve the UI in this respect, I think it would really help. I asked several members of my team and none of them could figure this out (we kept closing the “Select field” popup in order to access the one understand), delaying an improvement we were trying to make by about two weeks.


Kathryn, thanks for the feedback, and sorry this issue delayed your work. I agree it’s something we should fix. Glad you were able to get things working.

I dont get any fields to be selected for the filters… Looks like a similar issue, I get only one blank pop up…

What version of Skuid are you running? It looks like you’re using an OData data source here? I think there may be a fix available for the issue you’re encountering.

I am new to Skuid and not sure where to check the version.


In the Salesforce Setup, search for “Installed packages”. you should see the installed Skuid version there.

Any infos related to updating the Skuid version can be found here:


This is the screen I see and there is no option to check salesforce version on this screen.

This would be under the Salesforce setup section.

In the Quick Find, search for “Installed Packages”.