Can you add an aggregate table as a Chart Action

Please help.

I created a Basic model and a Aggregated model on the same sObject. I was able to successfully create a summary table using the aggregated model and create a drawer showing the detail using the basic model. I was so proud of myself! So then I went a step further and tried to add the aggregated table as a chart action on a chart I created. And then added the detail as a drawer on the chart action table. The problem is that the aggregated table is not showing any records, but the detail drawers ARE showing the correct data. That tells me something is working correctly - but why isn’t the table populated?

I made sure that I made the grouping field alias the same as the actual field being grouped. And added this field in the Context.


Am I missing something?

Thanks in advance

Huh … you’re trying to open a drawer from a chart action? Can you record a video of what you’re trying to do?


Sorry I can’t make a video as all the data in sensitive, nor does my work computer allow me to create videos. I am trying to open a popup from a chart. The table on the popup is from an aggregate model that has a grouping on AccountID. I then have a drawer on this table, that shows the detail records. The detail records are showing, but the aggregate table is not.


Hey Monie,

I can’t seem replicate this issue locally.

What you have looks very close, almost like the fields in your table don’t have the right names for some reason. have you tried re-adding the fields to the table?