Build Page Assignment Pack Button Not Working

My button for building page assingment packs isn’t working, and it looks like it’s because I don’t have the snippet skuid.pageAssignments.packAll. I’ve attached what the snippets look like for my “Page Assingment” page. Could someone send this my way or give any insight into why its not triggering?


This is a guess, but there is one UX issue with Page Assignment Packs if you are using the Package All Page Assignments Global Action (which from your screenshot, it looks like you are). After filling out the Packaging Options tab, you have to click on the Choose Pack tab and either give your new Pack a name, or select an existing one to overwrite. If you don’t do one or the other, you’ll get the following error message:

There was an error creating the "null" Page Assignments Pack:<br>The Static Resource name can only contain alphanumeric characters, must begin with a letter, and must be unique.: Name 

It’s something we’ll address in a future release. However, your issue could be something completely different. What error are you getting?

There was no error message just that clicking the button didn’t actually do anything. Tried your solution and it worked though. Thanks a lot!

Glad you got it working.  We’ll keep testing the page pack mechanism and add your process to the test plans. 

The UX issue I mentioned in the previous comment has been addressed in Banzai Update 5. The Package all Page Assignments button is now disabled until you either give the pack a name or select and existing pack.


Glad to hear that workaround did the trick! Thanks for helping us track down issues like this. Take care.