Brooklyn Problem: Cloning using the standard SF clone button

I recently updated our production environment to Brooklyn (9.3.1) and cloning via the standard SF button and clone page override is not working. I have tried two different objects and I get different errors but errors none the less. I tested in Rockaway in another sandbox and the exact same pages work properly. 

Any update on how to fix this issue would be greatly appreciated, as this is hindering our sales team workflow.

Same here in my production environment.  :/

http://community.skuid.com/skuid/topics/change-in-model-clone-behaviour

Tami,

Would you mind posting the error messages you get when you try to clone? Were they standard objects or custom objects?

Thanks!
Amy

Hi Amy,

I have attached the error below. The Customer Account is filled in my guess is that the Id is not carrying over properly with the update. With that said every change I have tried has not worked. Please let me know if you need login access to my org.




In addition to the error I provided associated lines are not cloning. For example. I am working on cloning quotes. If I retype the Account name I can get past the Account name missing error, the record saves but the quote lines do not update to the new quote. So the quote is saved without the lines. Any help getting this straightened out would really be helpful!

Any update on this Amy?

Doing a bit of digging it seems this issue existed in version 8.15.2 Iteration 7 (http://community.skuid.com/skuid/topics/clone-page-not-cloning-line-item) and was fixed by or before version 8.15.10. Could there be revert in code that is causing this issue again 9.3.1

Updating to version 9.3.3 has fixed the cloning issue. Thank you!

Tami,

Glad to hear that! 

Thanks!
Amy

Amy, the release notes don’t show anything related to Cloning.  Was a bug found and addressed?

Not technically; our developers have looked into it and aren’t sure why your and Tami’s pages weren’t working, since they could see that the previous cloning issue was fixed in Iteration 2 and weren’t able to reproduce your issue on any of our orgs. Sorry to give such a murky answer.

Thanks!
Amy