Blank fields won't allow model to save

I have a skuid page with 7 editable fields for a user to potentially update. If a user deletes a number and leaves any of the editable fields blank, it will not save the model. It will look like it saved, but if you refresh the page the previous numbers reappear as if nothing was changed. However, if a user replaces a number with zero, then it will save.

This page is used monthly and we did not experience any issues until we installed v7.24. I remember that we were able to leave fields blank before. Any ideas why this is not allowing us to save the model?

Thanks.

Chelsea,

Do you have any errors in the javascript console?
I’m assuming none of the fields are required in the ui or SFDC?

Hi Matt,

I do not have any of these fields as required in SF or in the skuid UI.

Here’s the only thing that popped up in the console, but don’t think it’s related?

Here’s the text if it’s hard to read:
Failed to load resource: the server responded with a status of 404 (Not Found)
https://login.salesforce.com/17181/logo180.png

I tried the above on another skuid detail page and got the same issue. When I deleted a number from a field and left it blank, the page does not recognize it as a change and will not allow me to save or cancel the model. So, I’m guessing the same thing is happening in my example above (I have a run multiple actions button for Save, which would allow me to click the button unlike the standard save/cancel).

If I remember correctly, I used to be able to delete a field and save - it would recognize it as a change. Anyone else having this problem?

Chelsea…That error is always present.  It is unrelated.  Can you post your XML here?  We can try to replicate what you are seeing.

Hi Bill,

I just created a simple Opportunity detail page with the amount and the description field to show you. It’s returning the same issue and will be easier than the other examples as it has a lot of custom objects.

If I delete the amount field, the save/cancel buttons do not allow me to save because it does not recognize a change. However, if I delete the description field, it does recognize the change…

We’ve noticed the same issue on both Google Chrome and IE.

<skuidpage unsavedchangeswarning="yes" personalizationmode="server" showsidebar="true" showheader="true" tabtooverride="Opportunity">
   <models>
      <model id="Opportunity" limit="1" query="true" createrowifnonefound="false" sobject="Opportunity">
         <fields>
            <field id="Name"/>
            <field id="CreatedDate"/>
            <field id="Amount"/>
            <field id="Description"/>
         </fields>
         <conditions>
            <condition type="param" enclosevalueinquotes="true" operator="=" field="Id" value="id"/>
         </conditions>
         <actions/>
      </model>
   </models>
   <components>
      <pagetitle model="Opportunity" uniqueid="sk-3shIqH-72">
         <maintitle>
            <template>{{Name}}</template>
         </maintitle>
         <subtitle>
            <template>{{Model&#46;label}}</template>
         </subtitle>
         <actions>
            <action type="delete"/>
            <action type="clone"/>
            <action type="share"/>
            <action type="savecancel" window="self"/>
         </actions>
      </pagetitle>
      <basicfieldeditor showsavecancel="false" showheader="true" model="Opportunity" mode="read" uniqueid="sk-3shIqH-73">
         <columns>
            <column width="50%">
               <sections>
                  <section title="Basics" collapsible="no">
                     <fields>
                        <field id="Name"/>
                        <field id="Amount"/>
                        <field id="Description"/>
                     </fields>
                  </section>
               </sections>
            </column>
            <column width="50%">
               <sections>
                  <section title="System Info">
                     <fields>
                        <field id="CreatedDate"/>
                     </fields>
                  </section>
               </sections>
            </column>
         </columns>
      </basicfieldeditor>
   </components>
   <resources>
      <labels/>
      <css/>
      <javascript/>
   </resources>
   <styles>
      <styleitem type="background" bgtype="none"/>
   </styles>
</skuidpage>

Chelsea…Thanks for posting this page.  I was able to replicate what you are seeing.  It seems to affect number or currency fields.  I also tried clearing a number field in my sandbox on a different page.  I get the same issue.  The Save/Cancel does not ‘light up’ to allow me to save.  We need to get this in front of the Skuid team to fix.  I am going to send an email to support@skuidify.com and reference this problem.

Great, thanks for your help!

Thanks for reporting the problem.  Everyone needs this fix.

Yes, we need it!

Looks like Zach is working on it.  See reply here.

https://community.skuidify.com/skuid/topics/removal-of-all-numbers-from-a-number-field-on-a-table-do…

This has been addressed in Banzai Update 6 - Patch 1 (7.27.1), now available from Skuid releases page.