Banzai Page Edit Error

I just upgraded my Sandbox account to the new Bonzai RC to test it out and every time I edit a Skuid page I get the following error:

SObject row was retrieved via SOQL without querying the requested field: skuid__Page__c.skuid__MasterPage__r

Justin,

This is a hunch, but does your User account have the Skuid Page Builder Permission set? MasterPage__c is a new field for Banzai, so if you’re upgrading, you won’t get permission to it automatically unless you have View All/Modify All or are using one of our Permission Sets.

I have the System Administrator profile with the Modify All permission. I just tried removing and adding my page builder permission set back, but that didn’t work either.

Looking at the Page Builder permission set it looks like all of the permissions are there. I have even created a new permission set to give modify all on the Page object and this still doesn’t appear to change anything.

The error sounds like that field wasn’t included in the query, not that I don’t have permission. I installed the Sandbox version from here: http://www.skuidify.com/skuidreleases

Yep, that error does indicate that the field wasn’t queried, not that you don’t have permission, but sometimes we dynamically build our queries and exclude fields which the user doesn’t have permission to access. This is a weird one. Would you mind granting us login access so that we could take a closer look? If you wouldn’t mind, shoot an email to support@skuidify.com with the Org ID once the access has been granted. Thanks!