"Apply" button not visible on table filter

Hello,
I have created automatic table filters on a page, and I noticed the “Apply” button does not show up as visible. Any help troubleshooting this is much appreciated. 

Hi Lauren,

It’s probably because the option to apply filters and search immediately is checked

On the table’s property , go to filters & Search tab and uncheck “apply filters and search immediately”

Hope it helps

Thank you Dave! So the apply button I am referring to is not the apply button that appears on the whole table when that option is unchecked, but the smaller button that appears in the dropdown to the left of “cancel” in the picture shown. On my other pages this is how the table filters appear

Thank you for the suggestion! I resolved the issue in CSS 

Lauren~

Glad you were able to resolve this!

Karen