Apostrophes break search on filter application?

Using the Skuid search, I can find a record that includes an apostrophe. For example, I can find a contact O’Brien. However, if I apply a filter to the search, I get no results, even if the record should be included in that filter. In fact, going back to the “all” version of the filter still doesn’t return results.

Can someone else confirm?

Any ideas here? It appears to be a bug.

Thanks,
Seth

Seth,  I cannot recreate your issue.  What version of Skuid is running in your org?  

Are you sure that the filter is set up correctly?  Does it return values if search is not selected? 

You can debug what is happening under the covers by opening the browser console and using this command   “skuid.$M(‘ModelName’).soql”   It will show you the query that is actually being generated. 

We’ve seen this issue before, and it has actually been fixed in the latest patch release of Skuid.  You can get an install link for Skuid 6.8.14 at the www.skuidify.com/skuidreleases page.

Thanks, Rob. We’re on 6.8.7.

I tried pulling the SOQL, but I’m not seeing the search term. Just ID in () with the results already in the () section. I’ll keep playing with it to see if I can find the query that actually has the search term.

Thanks, Ben!

This is indeed fixed by 6.8.14. Thank you.