All users can see skuid pages and Skuid Page Builder, even those without the "Skuid Page Viewer" or

Skuid 7.27 in a sandbox org. We have Skuid installed in our production org as well as sandboxes. We are not yet “live” with Skuid in production and have been building and testing in the sandbox. Once we setup non-admin users in the sandbox they ALL had access to any Skuid page as well at the Skuid page builder regardless of what permission set they have. I followed the steps in the getting started guide:… * Skuid Package is set to Auto assign/unassign * Skuid Page Viewer permission set is set to auto assign/unassign * Pages object sharing is set to “Public Read Only” * Page Assignments object sharing is set to “Public Read Only” * Profiles have access to visual force page created to redirect the “view” action on the Contact object I am wondering if my issue has to do with the visualforce page syntax? I initially tried the following syntax for use with Page Assignments from this guide:… as follows … … but that gave me an error message of: * Error: skuid_contact_detailed_view line 4, column 3: The markup in the document following the root element must be well-formed *Error Error: The markup in the document following the root element must be well-formed. I tried toggling the “{!redirect}&” to “{!redirect}?” with no luck. I then tried a variation of the syntax used on this guide:… I copied the ExportData, UploadImage, and Include VF pages as instructed and made a VF page as follows: This syntax was accepted, but I don’t know if that is causing my system wide access issues. Has anyone experienced a similar issue or have ideas on how to resolve?

looks like the post dropped by visual force syntax. What is the best way to add that to the post? as an image or some other tagging mechanism?

Post dropped my visual force markup. What is best way to add that to a post?


If it’s not letting you copy & paste it, a screenshot may work as well … 


The VF code will not affect your security issues. I’m pretty sure that your users have more permission that you think they do.  Are you sure that they do not have the Skuid Builder permission set?   Do they have Modify all permission?  Is the profile granted write access to the page object?