Adding a chart to a page causes my records not to load

Hi - I’m trying to add a chart to one of my pages.  I followed the chart piece of the Superbank launch webinar and the steps in the help document  Visualizations: Charts and Graphs.  I can preview it and it looks great.  But when I try to reload my page to see what everyone will see, nothing loads.  It also affects loading my other pages.  Any thoughts on what i’m missing? Thanks in advance!

Hey Kris, Whenever I run into these sorts of problems, my first step is to open the Chrome JavaScript console and see if any error messages are logged. Irvin

Thanks Irvin.  JavaScript console shows:  Failed to load resource: the server responded with a status of 404 (Not Found).  I’ve gone through all the settings for my chart on this page, but I don’t see anything that might cause this…

With the JS console open, do you see anything else if you hit F5 (reload the page)?

I do…  I see:

‘Attr.nodeValue’ is deprecated. Please use ‘value’ instead.skuid__SkuidJS:22

Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user’s experience. For more help, check http://xhr.spec.whatwg.org/.
VM1052:2

Uncaught TypeError: undefined is not a function

Don’t you just love messages like “… detrimental effects to the end user’s experience. …”. Sorry, a little levity on a Saturday afternoon is good for the soul. Hard to say without seeing your page. Usually, folks will post their XML or allow the Skuid team support access to the Org.

Here is my XML:



































<skuidvis__chart model=“ModelPatientEventsSR” maintitle="{{Model.labelPlural}}" type=“column”>






none
day
calweek
calmonth
calquarter
calyear









line
spline
area
areaspline
column
bar

</skuidvis__chart>



DOS







Add’l Co-Facilitator



Equine


Referring Org



Hours

sum





Cancellation Detail

































































And, i do love messages like that…detrimental effects…  :-)

Kris,

That “Uncaught TypeError: undefined is not a function” is likely where everything is coming to a halt, though I’m not seeing anything in your chart XML that definitely looks off. Are the PPT2__Date_of_Service__c and Cancellation_Reason__cfields showing up fine in the table? Would you be willing to grant us login access so that we could take a closer look? If so (and after doing so), just send support@skuidify.com the Org ID. Thanks!

Hi J,

The date of service and cancellation reason both show up fine in the table until i add the chart - then nothing will load.

I’m sorry I don’t know this, but where do i find my org id?  I looked around, but don’t see it…

Thanks!
Kris

Go to Setup > Administer > Company Profile > Company information > Salesforce.com Organization ID

Hey Kris,

Sometimes process of elimination can help.  Clone your page and remove elements one at a time until the page loads fine.  Just an idea to keep you moving.

Irvin

Found it.  Thanks Irvin!  

I tried removing different things in the chart to see if it will load, but the only way it loads is if i remove the whole chart…  Do you have a suggestion on which elements i might try removing?

Thanks for all the help!

What if you removed everything but the chart on the page?  
Maybe create a new page and recreate the chart.
Play with the chart options e.g. reduce the PPT2__Date_of_Service__c granularity options, etc.

I created a test page that just has my chart.  I reduced the chart granularity options etc…  same thing.  it won’t load.  

Remove the split field and see what happens.  

Removed the split field.  Nothing loads on my page.  It’s blank.

OK, silly question. If you create a new page with a very simple chart, does it load OK?

<skuidpage unsavedchangeswarning="yes" showsidebar="true" showheader="true" tabtooverride="Opportunity">   <models>
      <model id="Opportunity" limit="100" query="true" createrowifnonefound="false" sobject="Opportunity">
         <fields>
            <field id="Name"/>
            <field id="CreatedDate"/>
            <field id="StageName"/>
            <field id="Id"/>
         </fields>
         <conditions/>
         <actions/>
      </model>
   </models>
   <components>
      <pagetitle model="Opportunity">
         <maintitle>
            <template>{{Model.labelPlural}}</template>
         </maintitle>
         <subtitle>
            <template>Home</template>
         </subtitle>
         <actions>
            <action type="savecancel"/>
         </actions>
      </pagetitle>
      <skuidvis__chart model="Opportunity" maintitle="{{Model.labelPlural}}" type="donut" subtitle="by Stage">
         <dataaxes>
            <axis id="axis1"/>
         </dataaxes>
         <categoryaxes>
            <axis id="categories"/>
         </categoryaxes>
         <serieslist>
            <series valuefield="Id" splittype="field" aggfunction="count" splitfield="StageName"/>
         </serieslist>
         <colors/>
         <legend layout="horizontal" halign="center" valign="bottom"/>
      </skuidvis__chart>
      <skootable showconditions="true" showsavecancel="false" searchmethod="server" searchbox="true" showexportbuttons="false" pagesize="10" createrecords="true" model="Opportunity" mode="read">
         <fields>
            <field id="Name" allowordering="true"/>
            <field id="StageName" valuehalign="" type=""/>
            <field id="CreatedDate" allowordering="true"/>
         </fields>
         <rowactions>
            <action type="edit"/>
            <action type="delete"/>
         </rowactions>
         <massactions usefirstitemasdefault="true">
            <action type="massupdate"/>
            <action type="massdelete"/>
         </massactions>
         <views>
            <view type="standard"/>
         </views>
      </skootable>
   </components>
   <resources>
      <labels/>
      <css/>
      <javascript/>
   </resources>
</skuidpage>

My page is pretty simple, i think…?












<skuidvis__chart model=“PatientEventSR” maintitle="{{Model.labelPlural}}" type=“line”>











</skuidvis__chart>






Kris,

What browser (including version) are you using? Are you having this issue with all users, or is it only occurring when you log in as some Users?