Your connection is not private (Skuid site)

  • 1
  • Problem
  • Updated 2 years ago
  • In Progress
Is anyone else receiving this error? I've been getting it now for several weeks. I've tried 3 browsers on two different computers, nothing seems to work.
Photo of Brayden Smith

Brayden Smith

  • 1,078 Points 1k badge 2x thumb

Posted 2 years ago

  • 1
Photo of Karen Waldschmitt

Karen Waldschmitt, Official Rep

  • 8,220 Points 5k badge 2x thumb
Brayden~

Are you still having this problem? If so, here are a few things you may want to try:

Try running in incognito 
Make sure your computer's date and time are up to date
What anti-virus software are you using? If you're using avast, try turning off https scanning, clear out your cache, and finally reset chrome to default settings.

Thanks!
Karen