Where is the Field Property 'show column by default' functionality in V2?

  • 1
  • Question
  • Updated 4 days ago
  • In Progress
When in V2, in a Table, in a Field, there is no 'show column by default' checkbox. I've searched around but can't find it, even though we can give user the Table Configuration feature. Anyone know where I can find it?
Photo of Paul

Paul

  • 100 Points 100 badge 2x thumb

Posted 2 months ago

  • 1
Photo of Mark DeSimone

Mark DeSimone, Official Rep

  • 12,990 Points 10k badge 2x thumb
Hi Paul,

Try enabling the table's setting to "Allow column hiding," found under Display >> Configuration area. Once the table's set up with this enabled, each column should have a property labeled "Allow user to hide/show?"

Can you let me know if this answers your question?
Photo of Paul

Paul

  • 100 Points 100 badge 2x thumb
@Mark We have that selected but there is no 'Allow user to hide/show' in the Field Properties. We also updated this to the latest V2 version on Friday, hoping that that would resolve the issue, but it did not. Any other ideas?
Photo of Mark DeSimone

Mark DeSimone, Official Rep

  • 12,990 Points 10k badge 2x thumb
Hmm, if you're not seeing that setting, there are two possible reasons I can think of. First, the setting would only show up if the "Allow Column Hiding" setting was enabled on the table. Second, the field's setting is found by clicking the field in the table, not in the model. You may be looking in the model settings on the field - if that's the case, try following these screenshots and let me know what you see:

In the table settings, check this box first.



Then click on the field in the table, and see if you can find the setting here:


If this isn't what you see, could you send over similar screenshots of what you're seeing?
Photo of Paul

Paul

  • 100 Points 100 badge 2x thumb
Thanks, Mark. I'm definitely in the field on the table. See my screen shots below.





Photo of Paul

Paul

  • 100 Points 100 badge 2x thumb
@Mark just following up. Any thoughts on this? Just a reminder, we are using V2. We know this works in V1.
Photo of Paul

Paul

  • 100 Points 100 badge 2x thumb
@Mark do you have any input here??
Photo of Mark DeSimone

Mark DeSimone, Official Rep

  • 12,990 Points 10k badge 2x thumb
Hi Paul. Sorry for the delay and confusion. It looks like the ability to hide columns by default in V2 tables is available as of Skuid Spark Update 3. That release was in early access when I tested things out and shared my early responses, so that may have been why you didn't see the same settings.