We are unable to clone a model for a different object and build the same model.

  • 1
  • Question
  • Updated 2 months ago
  • Answered
We have two skuid pages on a custom object, and would like to clone these two pages on another custom object. We have cloned them and set these pages accordingly but unable to render these on skuid the same way we have done with the first custom object.
Photo of seetharam

seetharam

  • 120 Points 100 badge 2x thumb

Posted 3 months ago

  • 1
Photo of Luzie Baumgart

Luzie Baumgart, Official Rep

  • 2,444 Points 2k badge 2x thumb
This is under investigation :-)
Photo of Luzie Baumgart

Luzie Baumgart, Official Rep

  • 2,444 Points 2k badge 2x thumb
Summary
Based on what I saw in your org, there are two ways to solve the issue: either you add Page Assignments for the second custom object, or you add the Skuid page name to your Visualforce Markup.

Background information
As far as I can see, you use Page Assignments for the first object. The Page Assignment settings can be found in Skuid if you click "deploy" in the top menu bar. You need those Page Assignments because you used the Visualforce Markup without the Skuid page name. That is possible, please see this documentation:
https://docs.skuid.com/latest/en/skuid/deploy/salesforce/visualforce/skuid-page-visualforce-component.html#basic-overrides-with-page-assignments

Unfortunately, there are no Page Assignments for the second object, that's why it doesn't work. You can now either add Page Assignments like it has been done for the first object. Or, you can change the Visualforce Markup and include the Skuid Page name, then you wouldn't need Page Assignments. Please see this documentation:
https://docs.skuid.com/latest/en/skuid/deploy/salesforce/visualforce/skuid-page-visualforce-component.html#basic-overrides-without-page-assignments

Photo of seetharam

seetharam

  • 120 Points 100 badge 2x thumb
We have added page assignments and the new pages are working as expected. Great help! Thank you.