User Lost the Ability to Access Skuid Pages

  • 2
  • Problem
  • Updated 1 year ago
  • In Progress
  • (Edited)
Strange situation here.  We have a Tab in Salesforce Classic that users click to access a set of Skuid pages.  I have one user who has been accessing these pages successfully for months now.  Today, he clicks the Tab and only gets a blank screen.  No one else in the same profile is having this issue.  I verified that he still has the Skuid Page Viewer permission set.  I have tried removing and re-adding this, but no change.  Any ideas on what might be causing this behavior?
Photo of Paul Ginther

Paul Ginther

  • 896 Points 500 badge 2x thumb

Posted 1 year ago

  • 2
Photo of Skuidward Tentacles (Raymond)

Skuidward Tentacles (Raymond), Champion

  • 17,224 Points 10k badge 2x thumb
a completely blank screen might happen if there are zero records returned by the query and if create a new row is not selected in the model settings. It is possible that he no longer has records where he is owner.
Photo of Paul Ginther

Paul Ginther

  • 896 Points 500 badge 2x thumb
This is the "Master" Skuid page he's linking into so I'm not sure why he wouldn't at least see the Skuid construct, even if there are no records to display.  The first image is what he sees now.  The second is what he should see:





This user is at an upper management level so he should have access to data belonging to his direct reports in the Role Hierarchy, even if he has none of this own.
(Edited)
Photo of Mark DeSimone

Mark DeSimone, Official Rep

  • 11,050 Points 10k badge 2x thumb
Hi Paul, I don't see any errors surfacing on his page, but would you be able to check the browser console for any errors that are popping up? And, is the user able to see Skuid pages in other places?
Photo of Paul Ginther

Paul Ginther

  • 896 Points 500 badge 2x thumb
Hey Mark. I will check his browser console and see if there is anything there. At this point he cannot access any of the Skuid pages. I'll let you know if I find out anything from the browser. Thanks
(Edited)
Photo of Mark DeSimone

Mark DeSimone, Official Rep

  • 11,050 Points 10k badge 2x thumb
Another possibility is that it could be that he doesn't have access to the Visualforce pages that are in use here. Or, if the page(s) in question have models that are returning zero rows, you may need to set up their models to create a default row if no rows are returned. Since the user can't see any Skuid pages currently, this is less likely to be the issue.