Usage of Skuid page in the Salesforce Site

  • 1
  • Problem
  • Updated 1 year ago
  • In Progress
Hi all,

I'm using Skuid provided Custom component in my page builder. I have included that skuid page in the VisualforcePage. Now, I'm able to access that page in the Salesforce through Visualforce Page. But, When I'm trying to use the same page through Salesforce Site, I'm getting the remaining components except the custom component.

Any help to achieve this will be appreciated. Thanks in advance.
Photo of Priya

Priya

  • 478 Points 250 badge 2x thumb

Posted 1 year ago

  • 1
Photo of Bill McCullough

Bill McCullough, Champion

  • 12,436 Points 10k badge 2x thumb
Priya,

Does your Site user have access to the VisualForce page?  Also check that the Site user is licensed for Skuid.

Thanks,

Bill
Photo of Priya

Priya

  • 478 Points 250 badge 2x thumb
Thanks Bill for your reply.

Yes, Site User having access to the Visualforce page. Also, Site User is licensed for Skuid. In the Visualforce Page, I'm getting the remaining components other than Custom component. 
(Edited)
Photo of Bill McCullough

Bill McCullough, Champion

  • 12,436 Points 10k badge 2x thumb
Priya,

This may be question for Skuid to answer.  The only other thing I can think of is related to using version 10.  Skuid implemented a feature to make Skuid pages compatible with the Lightning Locker Service.  Skuid creates a Static Resource per Skuid page.  The cache control on that Static Resource is set to 'Private'.  Maybe try to set it to 'Public'?

Thanks,

Bill