URGENT!!! - Unable to view skuid page from two different user with same Standard System Admin profile

  • 1
  • Problem
  • Updated 5 months ago
  • In Progress
Hi,
I am having a problem from last two days  I was unable to view the skuid page from one user (System Admin) but when I switch to another user that's also a System admin with same profile I was able to view the same page in skuid. I thought It was a permission. Also I have checked the page viewer and page builder permission is assigned to both these users. Also this page load issue arises when I make any edit on the skuid page and reload it (maybe that's a coincidence). Also in the sharing settings for page and page assignment I have changed it to Public read/Write  for now. But Still I cannot load the skuid. Can you help me out whether some other permission needs to be fixed ?

Please find the attached screenshot of the error I am facing during the issue.

Photo of Abhishek prasad

Abhishek prasad

  • 80 Points 75 badge 2x thumb
  • frustrated

Posted 5 months ago

  • 1
Photo of Matt Sones

Matt Sones, Champion

  • 31,478 Points 20k badge 2x thumb
Can we assume that they both have skuid licenses? 

Is there any custom javascript running on the page?
Any static resources that one user may not have access to?
Photo of Josh Lewis

Josh Lewis

  • 1,218 Points 1k badge 2x thumb
I'd second the questions from Matt here -- Thanks for jumping in Matt! 

The skuid license portion will be key for starters, our documentation on that topic might come in handy as well: https://docs.skuid.com/v11.2.1/en/skuid/deploy/salesforce/user-access/

Thanks,

Josh 
Photo of Abhishek prasad

Abhishek prasad

  • 80 Points 75 badge 2x thumb
I had actually gone through the above skuid documentation configured everything as indicated. But was still getting the error for one user (which is assigned the skuid license) and for another admin user which has only viewer and page builder access and skuid admin access (not assigned license) was able to view the page.
I was able to find the page which was giving this js error. removed it and reloaded the page the page worked. The page that I had removed was part of a package page of an app that we were customizing.It has javascripts code written.
My concern is how i was able to view and load the same page which was giving error for one admin user and not for another user. For the time being, I have removed the default page of the app which was giving the error. and the rest custom pages are working fine.
May be I need to ask this with the product team of the app that we are customizing.

Thanks,
Abhishek