Unsaved alert message not showing!

  • 2
  • Question
  • Updated 11 months ago
  • In Progress
Whenever I try to open another page without saving anything on the previous pages, It  is not showing the unsaved changes alert message. I am wondering if that is the bug or if I am missing anything else. I have set the "Warn users if page has unsaved changes" To YES on skuid pages as well. Still not working.
Photo of ace

ace

  • 580 Points 500 badge 2x thumb

Posted 1 year ago

  • 2
Photo of mB Pat Vachon

mB Pat Vachon, Champion

  • 42,714 Points 20k badge 2x thumb
Hmmm... Do you have a master page with models on it?
Photo of ace

ace

  • 580 Points 500 badge 2x thumb
I have master page but the master page have nothing on it. Master page is blank.
Photo of mB Pat Vachon

mB Pat Vachon, Champion

  • 42,714 Points 20k badge 2x thumb
Then double check models.
Photo of ace

ace

  • 580 Points 500 badge 2x thumb
Model is also set to YES for alert.
Photo of mB Pat Vachon

mB Pat Vachon, Champion

  • 42,714 Points 20k badge 2x thumb
Oh yeah... do you have a popup blocker in your browser?
Photo of ace

ace

  • 580 Points 500 badge 2x thumb
No I don't have pop up blocker. If i try to refresh the page, it will show the alert message but if i try to move to another page it will not show alert message.
Photo of Don Souza

Don Souza, Employee

  • 1,160 Points 1k badge 2x thumb
Which platform/browser?
Photo of Allison

Allison

  • 1,158 Points 1k badge 2x thumb
I'm having the same issue but only in Lightning.  I think the model changes are being "activated" (the save button is highlighted) but I don't get the browser popup.  I do get it if I switch back to Classic