Unable to Save Fields to REST Model

  • 1
  • Problem
  • Updated 3 years ago
  • In Progress
I have semi-successfully set up a REST Model with Read/Write behavior.  I can successfully GET and PATCH records, it's awesome!

My problem: I'm asked for a Merge variable for my URL condition, but after I provide this and add the fields I want, I get an error message that states says "You do not have permission to update the value of this field: Composer Settings".  This is frustrating because it's the only way to see all my fields without having to manually add them all.

Any advice is appreciated, thanks!
Photo of Eulogio Gallo

Eulogio Gallo

  • 1,874 Points 1k badge 2x thumb
  • frustrated

Posted 3 years ago

  • 1
Photo of Thimo

Thimo

  • 1,280 Points 1k badge 2x thumb
Hi,

Is the Error you get from the REST service or from Skuid?
If it's something from your service, you probably need some proper authentication there.

But for the issue with the write behaviour:
- Make the model service type rest and read/write (as you already have, I assume)
- Add a new INSERT method with your service URL and type POST, also send the field values as JSON
- In the Fields point, add all the fields, you want to send in the request.

I hope that should work.

Do you use a public REST API? Then maybe I could try it out.
Photo of Eulogio Gallo

Eulogio Gallo

  • 1,874 Points 1k badge 2x thumb
The error is coming from SKUID when I try to save my page, after adding all the fields from my REST model. Like I said, my REST services work fine, the problem is that I need to supply a Merge Variable for my model to retrieve the fields I can add. However, once these fields are added and I try to save my SKUID page, I get the error above.
Photo of Eulogio Gallo

Eulogio Gallo

  • 1,874 Points 1k badge 2x thumb
Here are some screenshots of what I'm experiencing, hope this sheds some light on my issue.


This is the prompt for my merge condition.  Once I give this parameter, my REST model's fields get loaded and I can select them.



This is the error I get once I try to save my changes.  Any advice?