Ui-Only Field freezes preview

  • 1
  • Problem
  • Updated 1 year ago
  • Acknowledged
I have added my first Ui-field




I did not add the field to the page only created it.

I then selected preview and the page freezes forever.  



If I then delete the Ui-field the page displayes in preview.  Why
Photo of Bill Fox

Bill Fox

  • 7,954 Points 5k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
Hi Bill, are you running version 7.7 ? If not, can you try installing version 7.7 from the Skuid Releases page and see if this resolves the issue?
Photo of Bill Fox

Bill Fox

  • 7,954 Points 5k badge 2x thumb
I did download the new release and I can now search.  However, I receive the following error:
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
Okay, that explains it --- Skuid's Formula Field syntax does not support the HYPERLINK function. 

However, you could recreate this using a Formula like this:

"<a target='_blank' href='https://www.google.com/search?q="+{{Tax_Property_Address_Line_1__c}}+"'>Tax Owner Map</a>"
Photo of Bill Fox

Bill Fox

  • 7,954 Points 5k badge 2x thumb
I made the changes and I made it read only.  It shows up blank:


This is the error:
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
Can you post a screenshot of the Formula definition in the Page Composer? Looks like the formula was not entered correctly.
Photo of Bill Fox

Bill Fox

  • 7,954 Points 5k badge 2x thumb
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
Okay, I see what the problem is: add a double quote " at both the very beginning and the very end of of your formula.
Photo of Bill Fox

Bill Fox

  • 7,954 Points 5k badge 2x thumb
I have set as read only:
 

I added the doublw quotes:

But it shows like this:
Photo of Bill Fox

Bill Fox

  • 7,954 Points 5k badge 2x thumb
This has not been solved.
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
We are aware of the issue with Ui-Only Fields not always respecting the Read-Only setting, but we are considering that a separate issue from your original post.
Photo of Bill Fox

Bill Fox

  • 7,954 Points 5k badge 2x thumb
I agree the read only is not the first issue.
My intent for the field is to be html field that is a hyperlink field "Tax Owner Map" when clicked on will take them to "https://www.google.com/search?q="+{{Tax_Property_Address_Line_1__c}}"
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
I wouldn't use a UI Only field to try this.  I'd use a template.   Add a template to your field editor,  put the code you have put in your UI only Field formula into the body of the template.  Ensure it is read only.  You should be good. 
Photo of Bill Fox

Bill Fox

  • 7,954 Points 5k badge 2x thumb
Thanks Rob,

I did change to a template.  It generates a url that looks this:
https://www.google.com/search?q=%22+%3Cspan%20class=%22nx-merge%22%20data-field=%22Tax_Owner_Address...
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Triple braces.  

<a href= "https://www.google.com/search?q{{{Tax_Property_Address_Line_1__c}}}">{{{Name}}}</a>

Also - the value for Tax_Property_Address_Line_1__c is probably going to be a salesforce id.  You probably want to go through and get the name field behind (if it is one of your address concatenation things).  Somthing like: {{{Tax_Property_Address_Line_1__r.Name}}}
Photo of Michael L Barnes

Michael L Barnes

  • 176 Points 100 badge 2x thumb
Thank you!  Huge help!!