Trying to save a page when one field is over the character limit results in total data loss

  • 1
  • Problem
  • Updated 8 months ago
  • In Progress
Hi All, 

Seeking some skuid wisdom once again. I have a page that opens up with numerous account fields all defaulted to edit mode. Character limits are displayed on all text fields. Despite this users still exceed the limits from time to time when doing some data entry. 

Upon clicking save there is a standard Block UI > Save Models > Unblock UI action sequence to indicate that the models are saving. 

When users sometimes exceed character limits the page throws up an error in the background but then the page becomes stuck in the blocked UI mode. (see screenshot). When the page is stuck in the blocked UI mode they have to refresh the page and all the previous data entered is lost. 

Ideally I would like it so that if they do exceed a limit then we get an error only and they can still access the page to edit the overage. 

Any tips on how to accomplish this?

Screen:
Photo of Michael Schniepp

Michael Schniepp

  • 1,808 Points 1k badge 2x thumb

Posted 8 months ago

  • 1
Photo of mB Pat Vachon

mB Pat Vachon, Champion

  • 42,714 Points 20k badge 2x thumb
Have you enabled error message on Save action?

Photo of Mike Dwyer

Mike Dwyer

  • 3,390 Points 3k badge 2x thumb
Wouldn't this leave the UI active during the save, unless there were an error? And Michael's example shows that there already was an error message. Wouldn't the block-ui message be redundant then?
Photo of Michael Schniepp

Michael Schniepp

  • 1,808 Points 1k badge 2x thumb
The buttons are in a button set. I will get some images together if I cant record it.
Photo of Michael Schniepp

Michael Schniepp

  • 1,808 Points 1k badge 2x thumb
Sooo this is kind of embarrassing but it looks like the buttons were just pushed over to the edge of the page and they are still there :)
Photo of mB Pat Vachon

mB Pat Vachon, Champion

  • 42,714 Points 20k badge 2x thumb
hehehe ... yup. It's happened to me as well.
Photo of Michael Schniepp

Michael Schniepp

  • 1,808 Points 1k badge 2x thumb
Not sure why they move over, these 4 buttons are split in 2 button sets set inside 2 divisions of a responsive grid. Any tips on how to keep the buttons in frame would be great too!
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Its the error message that is pushing them out.   You might try to limit the size of the error message with some custom CSS.