There was an error attempting to load the requested page

  • 2
  • Problem
  • Updated 6 months ago
  • Solved
  • (Edited)
I am received the above error when attempting to load a page from a newly created tab. The VF page that controls the page include is included for the profiles experiencing the issue. The link to the page works fine for everyone, but the tab does not. 

It may be caused from two tables on the page being conditional rendered by profile. When I remove the conditions, both tables load fine. Very odd. 

Error when logged in as a user:



When logged in as myself:
Photo of Joe Lagorio

Joe Lagorio

  • 344 Points 250 badge 2x thumb

Posted 2 years ago

  • 2
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,320 Points 5k badge 2x thumb
Joe,

Can you check that the profiles have the Include Visualforce Page Access? 



Thanks!
Amy
Photo of Joe Lagorio

Joe Lagorio

  • 344 Points 250 badge 2x thumb
Yes the VF pages are included for all of the profiles in question. The VF page is loading correctly, it is struggling with the page includes. 
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,320 Points 5k badge 2x thumb
Joe,

The Include Visualforce Page is a standard Visualforce page that controls if the profile can see any included pages, so if those profiles don't have it they won't be able to see any included pages (even if they have access to the pages that are included). It's more of a security setting than an actual page. Would you mind checking the profiles to make sure the Include page is listed on their Enabled Visualforce Pages?

Thanks!
Amy
Photo of Joe Lagorio

Joe Lagorio

  • 344 Points 250 badge 2x thumb
Ahh sorry, I sped read your post. That did the trick! Thank you!