Text Area input shrunk after last patch

  • 1
  • Problem
  • Updated 2 years ago
  • Solved
We just installed 8.15.15 (from 8.15.9) to fix the chatter issue.  Now our text area boxes in edit mode have shrunk smaller than 1 line, and our users can't see their text that they have typed.  These are fields that have "Rows to Display" set to null.  When I change the Rows to Display to 3, everything looks fine.  I tested and see the same issue in Chrome and Firefox.

It is almost like the null is now considered a 0, when it used to be a 1.  I know it sounds like an easy fix to just go and add a value to the Rows to Display, but it isn't that easy when you have a zillion Skuid pages like we do...



In testing this, I added a value, saved the page, then tried to delete the value.  Now it won't let me!  It says the value must be > 0.  Except all the my existing text areas are null/0.

Photo of Chandra V

Chandra V, Champion

  • 6,966 Points 5k badge 2x thumb

Posted 2 years ago

  • 1
Photo of jili@heidrick.com

jili@heidrick.com

  • 2,032 Points 2k badge 2x thumb

Hi we are having the same issue.

We like the auto expanding feature, but it displays a very narrow text box, looking out of sync with other text fields which display as a normal text box. I understand this is due to the text area improvements introduced in the new patch.

We always display the text area fields in edit mode. That means we have to leave the  "Rows to Display" to null. If I set  "Rows to Display" to a higher number, we have a better user experience. But we don't have the auto expand any more. User will still have to scroll to see all contents.

Can you please advise? Any new patches coming out soon to fix this?

Thanks!

Photo of jili@heidrick.com

jili@heidrick.com

  • 2,032 Points 2k badge 2x thumb

I tried setting height: auto !important; for all text area. The text area looks taller, but it's cut off by the field editor:


Any other suggestions?

Photo of Matt Sones

Matt Sones, Champion

  • 31,478 Points 20k badge 2x thumb
Chandra & Jili,

Have you tried the 'update out of date themes' button since your upgrade? Usually that does the trick.
Photo of Chandra V

Chandra V, Champion

  • 6,966 Points 5k badge 2x thumb
That worked!  Thanks, Matt!
Photo of jili@heidrick.com

jili@heidrick.com

  • 2,032 Points 2k badge 2x thumb
Thanks Matt. Would it break other stuff? Can Skuid please confirm this is the right way?
Photo of Karen Waldschmitt

Karen Waldschmitt, Official Rep

  • 8,240 Points 5k badge 2x thumb
Yes, Jin Li, updating all your themes would be the correct first step. Please try that and see if you still experience this problem. 

Thanks!
Karen
Photo of jili@heidrick.com

jili@heidrick.com

  • 2,032 Points 2k badge 2x thumb
Hi when I updated all the themes in another sandbox, I see different changes. It is possible to revert the themes changes?
(Edited)
Photo of jili@heidrick.com

jili@heidrick.com

  • 2,032 Points 2k badge 2x thumb
So as you can see, the background of the field editor becomes white. Empty spaces keep the same background. UI is very inconsistent now. I tried in another sandbox with Update all themes. Same thing!

We didn't see all of these changes in the initial sandbox we performed the upgrade.

Please advise.