Table Filters not working with External Data Source

  • 2
  • Problem
  • Updated 3 years ago
I've successfully connected to an External data source (OData service) using Skuid Model Connect. I'm able to pull up a table and display data - search and define sort on the model. However, when I add a table filter I'm able to filter only once - that is, the filter works the first time I select a value after page load. The second and subsequent times, I get an error saying 'Filter could not be applied'.

Using skuid.model.getModel('External').soql and connecting directly to the OData service I've verified that my service accepts filter params. So am guessing Skuid is messing up request params for subsequent filter requests.

Also, if I change a filter AFTER I perform a search the the search works!
Photo of LVS

LVS

  • 92 Points 75 badge 2x thumb
  • confused

Posted 3 years ago

  • 2
Photo of J.

J., Official Rep

  • 7,470 Points 5k badge 2x thumb
Hi, LVS. I think that I've identified and patched an issue in our Dev Org that will address this. When you had an OData model with multiple conditions that would get enabled/disabled, we weren't removing the placeholders for the inactive conditions, which did in fact lead to messed up request params. Unfortunately, the fix didn't make it into the soon and coming Banzai Update 4, but it should be included in Update 5. Thanks for helping us track that down.
Photo of LVS

LVS

  • 92 Points 75 badge 2x thumb
Thanks J! Any idea when updates 4 & 5 are expected though?
Photo of J.

J., Official Rep

  • 7,470 Points 5k badge 2x thumb
Sure thing! Update 4 should be available on the Skuid Releases page later today. We don't have an official date for Update 5, but my best guess is sometime in the next week or two.
Photo of J.

J., Official Rep

  • 7,470 Points 5k badge 2x thumb
...and just like that, Banzai Update 4 is now available!