Table filter not being applied on search

  • 3
  • Problem
  • Updated 9 months ago
  • Solved
I have added a table filter for our Account page that allows the user to filter by OwnerId. We have around 500 user records so the filter is presented as a search box. When the user searches for a name, clicks on the name, it should filter the table, though it doesn't.

I checked this filter in an old sandbox on another version of Skuid, it works fine. The sandbox where this isn't working is running on version 11.2

Below is the error message I receive in the console.
Photo of Glenn Daly

Glenn Daly

  • 1,560 Points 1k badge 2x thumb

Posted 11 months ago

  • 3
Photo of Kevin

Kevin

  • 762 Points 500 badge 2x thumb
This reply was created from a merged topic originally titled Table Filter Bug in Millau (11.2.1) and also (11.2.2).

Ther following error occurred when I used the Filter Type is Select Option in Table.
I already updated the themes after upgraded the new version.

Please help to check.

skuid__SkuidReqsJS:1 Uncaught TypeError: Cannot read property 'effects' of undefined
    at skuid__SkuidReqsJS:1
    at Function.each (skuid__VendorJS:1)
    at I.handleSourceEffects (skuid__SkuidReqsJS:1)
    at I.P.activateFilter (skuid__SkuidReqsJS:1)
    at a.fn.init.Fe [as onItemSelect] (skuid__SkuidReqsJS:1)
    at a.fn.init.selectItem (skuid__SkuidReqsJS:1)
    at a.fn.init.s.fn.(/apex/anonymous function) [as actionAutocomplete] (https://xxx--skuid.cs6.visual.force.com/resource/1530176340000/skuid__SkuidReqsJS:1:482582)
    at HTMLInputElement.d.accessible.l.onChangeFunc (skuid__SkuidReqsJS:1)
    at a.(/apex/anonymous function).(anonymous function)._trigger (https://xxx--skuid.cs6.visual.force.com/resource/1530176345000/skuid__VendorJS:4:11900)
    at a.(/apex/anonymous function).(anonymous function).menuselect (https://xxx--skuid.cs6.visual.force.com/resource/1530176345000/skuid__VendorJS:5:10096)


Photo of Josh Lewis

Josh Lewis

  • 1,218 Points 1k badge 2x thumb
Glen and Kien,

This looks like a similar issue that has been brought to our developers. In that scenario, it look like the filters are not applied, but upon a refresh of the page, they are applied. Could you test and confirm if this behavior is occurring in your use cases? If so I'll link this to the existing known issue, and we will update you as soon as a fix is available.

Thank you,

Josh
Photo of Glenn Daly

Glenn Daly

  • 1,560 Points 1k badge 2x thumb
Thanks Josh, I can confirm when the page is refreshed, the filter is applied.
Photo of Kevin

Kevin

  • 762 Points 500 badge 2x thumb
Hi Josh,

How is the progress? Could you please resolve it quickly?

Thanks.
Photo of Chandra V

Chandra V, Champion

  • 7,526 Points 5k badge 2x thumb
Progress on this bug?  We are also affected by filters not working.  Our finding:
Multi-select or single select filter does not work properly. Choice is never applied and results updated.
Photo of Josh Lewis

Josh Lewis

  • 1,218 Points 1k badge 2x thumb
Chandra,

Are you observing that when the same page is refreshed that the filter is then applied? That is what we see here, so I'd like to confirm that you are seeing the same issue, or if you might have a slightly different, yet similar issue?

Thanks,

Josh
Photo of Ant Belsham

Ant Belsham

  • 1,022 Points 1k badge 2x thumb
Seeing the same issue (throws error but works ok on page refresh). Any fix yet?
Photo of Daniel Camp

Daniel Camp

  • 422 Points 250 badge 2x thumb
Josh,
Yes. Refresh the page and the filter is then applied.
Daniel
Photo of Dan B

Dan B

  • 462 Points 250 badge 2x thumb
Have this issue with all our pages using table lookup filters. Has this been fixed? Is there a workaround since this bug was logged 1 month ago?
Photo of Mark DeSimone

Mark DeSimone, Official Rep

  • 11,944 Points 10k badge 2x thumb
Official Response
Hello Glenn and everyone,

Thank you for your patience! Skuid has fixed the issue you raised, in which text entry-based filters are not registering a selection unless the page is refreshed (issue DSC-141) in the new 11.2.6 and 11.2.7 releases which are now available on the Skuid Releases page.


As a reminder, Salesforce does NOT allow reverting back to prior versions of managed packages. Skuid always recommends installing new versions in a non-business critical sandbox environment to test all mission critical functionality before installing into a production environment. We also recommend that you update out of date themes when you upgrade. Please let us know if you continue to encounter any problems with this issue after upgrading.
 
Thanks again for alerting us of these issues!