table filter "None" option oddity

  • 1
  • Problem
  • Updated 4 years ago
  • Solved
Photo of mB Pat Vachon

mB Pat Vachon, Champion

  • 42,714 Points 20k badge 2x thumb

Posted 4 years ago

  • 1
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
I've had the same thing happen.  It seems that "Create None Selected Option" property does not work well when working with subquery conditions, or multiple conditions. 

What I do is usually leave that option unchecked and then add another manual source as the first entry in my source list.  This manual source has the lable "None" and deactivates both conditions that are associated with the filter. 

If you make this manual source the first one in your list,  it will be the default on page load (unless you've got cookies enabled)  so you don't get the annoying  "---"  thing.   And it works more reliably to actually get your full data set back... 

Easy workaround.  Cheers. 
Photo of mB Pat Vachon

mB Pat Vachon, Champion

  • 42,714 Points 20k badge 2x thumb
Yup. Easy workaround. Thanks Rob.