Table filter dropdowns cut-off on short table.

  • 1
  • Problem
  • Updated 3 years ago
  • Not a Problem


Also, when I select a filter, I only see the very top of the grey "loading" bar that usually appears over the table. Looks like anything associated with the table can't overflow its boundaries.
Photo of Matt Sones

Matt Sones, Champion

  • 31,478 Points 20k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
This is an unfortunate side effect of adding a max height on your table.  I'd do two things. 
1. Make your filter a type ahead (so it doesn't drop down)
2. LImit the number of rows shown before pagination - This will bring up the loading indicator. 
Photo of Matt Sones

Matt Sones, Champion

  • 31,478 Points 20k badge 2x thumb
Rob,

I'm not sure I understand the max-height. I don't want my table to have a max height. It's the last thing on the page... let it be as big as it wants to be!
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Look at the display properties of the table.  You probably have table scrolling turned off.  But if you turn it back on you will discover some of the underlying checkboxes and properties are still turned on.  Turn them all off and you will be golden.  

Its a bug.  Yes.  Its a bug..