Table filter default option when none is not included

  • 1
  • Problem
  • Updated 3 years ago
I am creating table filters and I want there to be default filters set on page load. I have created a manual filter so the first selection will automatically load. It doesn't. Has anyone experience this?

Set the manual filter w/out cookies and "none selected" option


On page load I get this
Photo of Tami Lust

Tami Lust

  • 5,280 Points 5k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Is your condition "filterable default on"  and does the initial value match what you have as "Approved"   I think these need to be in synch... 
Photo of Tami Lust

Tami Lust

  • 5,280 Points 5k badge 2x thumb
Rob.

My condition was set to filterable default off. So that makes sense. I switched it to filterable default on.  When you ask about the initial value do you mean are there records that have "Approved"? If so, yes there are records that have that value set. 

The page now loads empty with the filter button showing "----"
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
You have to make sure you have content  in the "value" section of your condition.  Then when your condition is "Default On"  it will start with that value and let the user select somthing else.

 
(Edited)
Photo of Tami Lust

Tami Lust

  • 5,280 Points 5k badge 2x thumb
That makes perfect sense! It is working now. Thank you!