table export appends row Id when Use Table Columns as Export Columns is false

  • 1
  • Problem
  • Updated 1 year ago
  • Solved
  • (Edited)
Steps to reproduce:
Running 8.15.15.
  1. Create a table and enable exporting. 
  2. Uncheck 'Use Table Columns as Export Columns'. The 'Append Row Id Column' field is hidden. 
  3. Add some fields to the export columns, but do not add the Id field. 
  4. Preview and export.

Expected result: Only the fields added to the Export Columns are exported.
Actual result: the Id field is appended to export columns. This appears to happen regardless of whether the hidden 'Append Row Id Column' field is checked or unchecked.
Photo of Matt Sones

Matt Sones, Champion

  • 31,478 Points 20k badge 2x thumb

Posted 2 years ago

  • 1
Photo of Mark DeSimone

Mark DeSimone, Official Rep

  • 11,050 Points 10k badge 2x thumb
Official Response
Thank you for your patience! Skuid has fixed the issue you raised (issue CORE-12) in the new Brooklyn Update 1 - Iteration 7 (9.5.7) release which is now available on the Skuid Releases page.

As a reminder, Salesforce does NOT allow reverting back to prior versions of managed packages. Skuid always recommends installing new versions in a non-business critical sandbox environment to test all mission critical functionality before installing into a production environment. We also recommend that you update out of date themes when you upgrade. Please let us know if you continue to encounter any problems with this issue after upgrading.
 
Thanks again for alerting us of these issues!
(Edited)