StaticResource Slow Packaging

  • 1
  • Problem
  • Updated 2 years ago
I am trying to package 2 pages into a staticresource but it would not package after 20 hours of loading. Has anybody had this issue?
Photo of Hayden

Hayden

  • 90 Points 75 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Matt Sones

Matt Sones, Champion

  • 31,478 Points 20k badge 2x thumb
Hayden,

It shouldn't even take a minute to package two pages. Have you tried again after reloading the page?
If it doesn't complete after 30 seconds or so, check your console for javascript errors. (Ctrl+Shft+J) in Chrome.
Photo of Hayden

Hayden

  • 90 Points 75 badge 2x thumb
Hi, Matt. I am unable to check for javascript errors while it is in the process of packaging, but when i refresh the page and check there are no errors on the console.
Photo of Matt Sones

Matt Sones, Champion

  • 31,478 Points 20k badge 2x thumb
If you right click somewhere on the page (while the packaging is happening) and click 'Inspect', can you get to the dev console?
Photo of Matt Sones

Matt Sones, Champion

  • 31,478 Points 20k badge 2x thumb
Actually, it would be even easier to open the console and leave it open while you package to see if you get any errors.
Photo of Hayden

Hayden

  • 90 Points 75 badge 2x thumb
Thanks for the suggestion, Matt. I did that, but am not getting any errors. Just for some more context, the two pages I am packaging are

1. A queue which is to override a standard tab page and
2. A detail page to override a detail page of the same object

This object is a part of a managed package (I have cloned the 3 necessary VF pages to support this), but when I go to the object itself in the setup and attempt to override the page with the new vf page, I cannot locate it in the list (In the past I could, and was successfully overriding). My queue page references this VF page so not sure if this has anything to do with it?