SOS- Attempt to de-reference a null object after update

  • 2
  • Question
  • Updated 8 months ago
  • Answered
Hi! A lil help please! I was updating our production environment to 11.1.4. It had been in 10. Went through progression but there was no link to 11.1.1 or 11.1.3  Installed 11.1.4 but am now getting the Attempt to de-reference a null object error... 
as you can see below it isn't getting to load the skuid page, same is true if I try to preview the skuid page

The url seems well formed. Have tried same in Sandbox works fine.

Thanks in advance!
AP
Photo of Arne-Per Heurberg

Arne-Per Heurberg

  • 1,336 Points 1k badge 2x thumb

Posted 8 months ago

  • 2
Photo of Paul Heald

Paul Heald

  • 420 Points 250 badge 2x thumb
we had the same issue and traced it to a field in one of the models that was not accessible by the system administrator profile, once access was granted the page loaded correctly. Interestingly we were not loading the model in question on page load. 
Photo of Arne-Per Heurberg

Arne-Per Heurberg

  • 1,336 Points 1k badge 2x thumb
Found same to be true for other pages. This one I have checked all 100+ fields.. Can't find an errant field.
Thank you for the help!
(Edited)
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
Arne, we have a new version available that resolves this issue, if you give the approval we can push the new version to your production org.
Photo of Arne-Per Heurberg

Arne-Per Heurberg

  • 1,336 Points 1k badge 2x thumb
That would be awesome! Can you push to sandbox as well as it showed up there afterward.
Thanks again. Lifesa saver!
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
Arne, if you post your Org Ids we will take care of it. Thanks.
Photo of Arne-Per Heurberg

Arne-Per Heurberg

  • 1,336 Points 1k badge 2x thumb
00D36000000HV35 and 00DV00000088zAF . Thanks again!
Photo of Luzie Baumgart

Luzie Baumgart, Official Rep

  • 1,310 Points 1k badge 2x thumb
Hi Arne, you can also install this now by yourself, the new version has been released:
https://www.skuid.com/releases/salesforce/

Please let us know if you still face any issue after the upgrading.
(Edited)