Some time in skuid page link is not working in lighting mode in salesforce org , How can i fixed that ?

  • 1
  • Question
  • Updated 1 year ago
  • Answered
Some time in skuid page  link is not working in lighting mode in salesforce org ,  How can i fixed that ? 

We have try to fixed but issue in not fixed anyone tell me some relative issue , How can i fixed that , 

We have used skuid page throw vf page .
Photo of Rajesh Kumar

Rajesh Kumar

  • 738 Points 500 badge 2x thumb

Posted 1 year ago

  • 1
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,200 Points 5k badge 2x thumb
Rajesh,
  • How is the link set up? Is it automatically a link, like through the name of a field, or did you set up the link through a template field?
  • How are you trying to access the link, just clicking on it normally or right-clicking and opening in a new window? 
  • Does the link work if you preview the Skuid page and try it while not in Lightning?
Photo of Rajesh Kumar

Rajesh Kumar

  • 738 Points 500 badge 2x thumb
Hi amy 

I am talking about record link like table has 5 record and click table in name column after automatically  redirect separate  record ,

In lighting mode is not working proper when ever click to name record in table or lookup type page in redirect but some time  show same / current page or some time redirect record is open but tab is not separately it means try to click open new tab but new tab in parent page and current page in open record .

That is very crucial problem in skuid app.

Skuid app provide to lighting look and feel right but not working 100 % as a lighting behavior in sales-force.

Thanks 
Rajesh
(Edited)
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,200 Points 5k badge 2x thumb
Rajesh,

Unfortunately, I'm still having trouble reproducing this behavior, so here are some more questions:

What version of Skuid are you on?
What browser are you using?
Could you post some screenshots of what you're seeing?
Photo of Rajesh Kumar

Rajesh Kumar

  • 738 Points 500 badge 2x thumb
Sure Amy ,

I am sharing some information :

1. Version NameBrooklyn Update 1 - Iteration 4,
2.Version Number9.5.4
3.First Installed Version Number8.15.8.
Brawser : Use chrome & Firefox both .


I am  highlighted all clickable point but not response  still have same page.
(Edited)
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,200 Points 5k badge 2x thumb
Rajesh,

I believe this is a limitation dealing with Visualforce pages within Lightning. If you have a Visualforce page with reference links in Lightning, right-clicking to open in new tab won't always work. If you just click the reference normally (to open in the same window) it should always work. Check out the release notes about this topic here and let me know if you see different behavior.