Slow Page Loads

  • 4
  • Problem
  • Updated 2 years ago
  • In Progress
Page loads seem to be consistently slow on my org, I dug a bit deeper into it using the Dev Console and there are a lot of logs that say "ENTERING_MANAGED_PKG", these logs take up 4-5 seconds in the timeline, is this expected?  Why is it taking so long to load pages?

Here's a screenshot to demonstrate what I mean.  

Photo of Tyler Neal

Tyler Neal

  • 760 Points 500 badge 2x thumb

Posted 2 years ago

  • 4
Photo of Kathryn Castle

Kathryn Castle

  • 814 Points 500 badge 2x thumb
I've had this issue too. If you haven't taken a look at this help doc, I can recommend it. It goes into quite an impressive amount of detail to help diagnose page load speed issues. 

Other than that, I'd look into how many models you're loading on your page, how many fields each of those models are loading in and what the max number of records to be returned is to set. In general, the more models, the more fields and the higher the max number of records, the slower your pages will become. If you can't delete any models, consider switching some of them to not load on page load. Instead, you can set other models to query them as they load or query them when a user clicks on a tab (just to give a few examples - happy to provide further details if needed).

Another thing you might look into is whether you have any JS snippets or CSS files on your Skuid page. If so, consider removing those and referencing them as static resources instead.

Addressing these points should improve things somewhat. Let me know how you get on!
Photo of Tyler Neal

Tyler Neal

  • 760 Points 500 badge 2x thumb
Hey Kathryn,

I've looked through that page at least 10 times already :(

The page that I posted the screenshot for above only has 1 model loading on page load, all other models are loaded via tab set actions or buttons.

Additionally, I have no custom JS or CSS added to the page at all.

Any ideas you or others may be able to suggest would be greatly appreciated.

Thanks,
Photo of Kathryn Castle

Kathryn Castle

  • 814 Points 500 badge 2x thumb
Hmm, well that's not what I was expecting! :)

That being the case, my best guess is that either you have a lot of components on the page (more XML to render) or you're loading in a large number of records. If it's the latter, you could look into reducing the record limit and dynamically loading in additional records after page load.

Saying that, I actually tested one of our faster pages today using the Salesforce developer console and had pretty much the same result you did.

I don't know how feasible it is from Skuid's side, but it'd be nice to see either some documentation as to what is happening during the EXECUTING_MANAGED_PKG event or else some more verbose logging.
Photo of Tyler Neal

Tyler Neal

  • 760 Points 500 badge 2x thumb
Bumping this to get more attention, still having issues, would like to get to the bottom of why this is happening.
Photo of Karl Li

Karl Li, Employee

  • 708 Points 500 badge 2x thumb
Hey Tyler, just checking what version of Skuid are you using? 
Photo of Tyler Neal

Tyler Neal

  • 760 Points 500 badge 2x thumb
Hey Karl,  I'm using 8.15.10 which I believe is the latest version.