Skuid session expired after logging in

  • 11
  • Problem
  • Updated 2 years ago
  • Solved
Hi,

Myself and several of our users have a problem where our skuid sessions expire shortly after logging in. This occurs on a daily basis, right after logging into Salesforce. We are running the latest Rockaway 8.13 release. Could you provide any insight on how to correct this annoying issue?

Thanks,

John
Photo of John Watson

John Watson

  • 584 Points 500 badge 2x thumb

Posted 2 years ago

  • 11
Photo of Kyle Mathis

Kyle Mathis

  • 576 Points 500 badge 2x thumb
Our environment is also having this issue. If anyone has insight that would be great!
Photo of Karen Waldschmitt

Karen Waldschmitt, Official Rep

  • 8,220 Points 5k badge 2x thumb
John and Kyle~

Can you look at the Salesforce setup menu and check this for your profiles?

Setup menu --> Administer --> Manage Users --> Profiles --> Click on desired profile name --> Under System, Click Session Settings and you should see the screenshot below ... 



Thanks!
Karen
Photo of John Watson

John Watson

  • 584 Points 500 badge 2x thumb
I guess my issue is unclear. After a session timeout or new session, the user logs in again, then skuid says the session has timed out after the salesforce login event. This is the problem. We have no problems like this with our native pages, only with skuid. Our session settings are set to 12 hours for admins and 8 for users, so the session should not be timing out within a minute of logging in. Also when this message appears, users have to simply refresh the page to get working again. It's a very annoying issue because users lose any work they started before skuid decides to kick people off.
(Edited)
Photo of Megan Minahan

Megan Minahan

  • 726 Points 500 badge 2x thumb
This has been happening for our skuid instance too. Would love to hear if there is a solution!
Photo of Matt Sones

Matt Sones, Champion

  • 31,478 Points 20k badge 2x thumb
Me too. Although, it has not been consistent. I haven't been able to identify a pattern.
(Edited)
Photo of Karen Waldschmitt

Karen Waldschmitt, Official Rep

  • 8,220 Points 5k badge 2x thumb
Hi~

Sorry it's been so annoying ... Are you seeing this on the same tab you just logged into Salesforce on or on another tab that had another Salesforce page open previously?

Thanks!
Karen
Photo of Bill McCullough

Bill McCullough, Champion

  • 12,436 Points 10k badge 2x thumb

Karen,

Our users are reporting that it happens on the same tab.  They can be logged off as soon as they login or they are editing page and click 'save' when they see session expired popup.

Thanks,

Bill

Photo of Megan Minahan

Megan Minahan

  • 726 Points 500 badge 2x thumb
We haven't been able to identify a pattern either. I know reps may have a few tabs open, and they try to close all of their other tabs, but the session still logs out. This has been happening to me in the developer instance as well. I'll navigate to a different tab, then go back to the developer tab and will receive the same error that I commented above
Photo of Bill McCullough

Bill McCullough, Champion

  • 12,436 Points 10k badge 2x thumb
Karen,

We are experiencing the same problem.  This started happening for a customer of ours last week.  They would login and within 5-10 minutes receive a session expired message as Megan reported. We haven't been able to pinpoint a specific why this has been happening.  The frequency seemed to ebb and flow.

One thing that we think we have found is that it seems to affect Skuid pages that use a Master Page.  We have users who use both Master and 'non Master' Skuid pages.  Only the group using Master pages seems affected.  We are on Banzai 7.39.

For those affected by this, please have your team try accessing Salesforce using the Privacy or Incognito mode of the browser.  This seems to help alleviate the early session termination.

Thanks,

Bill
(Edited)
Photo of Megan Minahan

Megan Minahan

  • 726 Points 500 badge 2x thumb
That is interesting Bill. For us, we have multiple departments using the Master and Child Pages, but only one department is experiencing these session timeouts. Just wanted to provide a little more insight
Photo of Bill McCullough

Bill McCullough, Champion

  • 12,436 Points 10k badge 2x thumb
Megan,

Do you have departments that don't use Master/Child pages? Are they experiencing any problems? We have seen something similar to you. It's mainly one group that has seen the problem. We have 2 groups using Master/Child pages. Only 1 has seen the problem in any 'consistent' way. The other group rarely sees it.

Thanks,

Bill
(Edited)
Photo of Megan Minahan

Megan Minahan

  • 726 Points 500 badge 2x thumb
Bill, We have moved every department over to use Master/Child Pages all of the departments have the pages built and formatted very similar to each other. All departments, but this one department rarely see the session timeout error
Photo of John Watson

John Watson

  • 584 Points 500 badge 2x thumb
We also use a branded master page so our skuid ui doesn't look like salesforce
Photo of Ben Hubbard

Ben Hubbard, Employee

  • 12,490 Points 10k badge 2x thumb
I think this has something to do with how salesforce handles sessions when the standard header is turned off. Is anyone experiencing this with the standard salesforce header turned on?
Photo of Megan Minahan

Megan Minahan

  • 726 Points 500 badge 2x thumb
We have the standard Salesforce header turned on
Photo of Matt Sones

Matt Sones, Champion

  • 31,478 Points 20k badge 2x thumb
I have several users reporting this issue from locations around the country. I've experienced it myself. Occasionally, a save action is causing the not logged in error. Doesn't seem to be related to other open tabs, as user report when only one browser tab is open. I never have only one tab open, so I wouldn't know. Can't reproduce consistently.
Photo of Kyle Mathis

Kyle Mathis

  • 576 Points 500 badge 2x thumb
This is exactly what's happening with us.
Photo of Ben Hubbard

Ben Hubbard, Employee

  • 12,490 Points 10k badge 2x thumb
Since this is happening across many versions of Skuid and we didn't make any changes around the time this started, we'll bring this up with Salesforce and see if they can come up with a resolution. Somehow either the session token or the CSRF token is becoming invalid for JS Remoting requests. 
Photo of Matt Sones

Matt Sones, Champion

  • 31,478 Points 20k badge 2x thumb
Thanks, Ben. Let us know if there's any way we can 'me too' your case with salesforce.
Photo of Bill McCullough

Bill McCullough, Champion

  • 12,436 Points 10k badge 2x thumb
Ben,

We have a case open with Salesforce on this issue.  Let me know if you want to reference our case number.

Thanks,

Bill
Photo of Karen Waldschmitt

Karen Waldschmitt, Official Rep

  • 8,220 Points 5k badge 2x thumb
Hi community~

So sorry this is still not resolved yet, still working through it with Salesforce ... Here's a question from them: when your users encounter this problem, what browser are they using? Is it any better from a different browser (they recommended Chrome)?

Thanks!
Karen
Photo of John Watson

John Watson

  • 584 Points 500 badge 2x thumb
We use chrome across our org to access SFDC. I personally have tested Edge and had the same issue.
Photo of Matt Sones

Matt Sones, Champion

  • 31,478 Points 20k badge 2x thumb
We also use Chrome. Haven't tried anything else.
Photo of Megan Minahan

Megan Minahan

  • 726 Points 500 badge 2x thumb
We all use Chrome
Photo of Sarah Hughes

Sarah Hughes

  • 454 Points 250 badge 2x thumb
We are experiencing the same issue. Our users are using both IE and Chrome, though mostly Chrome and the timeout is happening with both browsers.
Photo of Tony Sirna

Tony Sirna

  • 976 Points 500 badge 2x thumb
I've had this error come up on both Firefox and Chrome.
Photo of Karen Waldschmitt

Karen Waldschmitt, Official Rep

  • 8,220 Points 5k badge 2x thumb
Hi again community~

I hate to do this but Salesforce is asking for
  • a test user in an affected org 
  • a GoToMeeting with an affected user (and me) to see the behavior
If you are okay with both of the above and are available tomorrow sometime between 9-11 am, 11:30 am-12:30 pm, or 2-3 pm PST, please let me know and we can coordinate and get the details offline.

Thanks so much for your support and patience!!!
Karen
Photo of John Watson

John Watson

  • 584 Points 500 badge 2x thumb
Hopefully my call today will help expedite the fix
Photo of Gary

Gary

  • 1,518 Points 1k badge 2x thumb
Probably not much help, but here goes:

I'm having this issue as well. From the error message, it looks like Skuid is getting (or thinks it is getting) a HTML response - so the error message is "Error parsing json response: Unexpected token <"

I open a page in the page editor and open the Chrome dev console, and monitor the network tab. I can see constant pings to apexremote. Once I get the pop up about "Are you sure you want to leave?", I check the network calls - they are all 200, and they all look like the received a JSON response. I thought maybe one of them would show a different code (e.g. 401 Unavailable?), or at least one of them would have received html that looked like a "You need to login" page.

The curious thing is, I don't actually seem to be logged out, so I don't think the session has actually expired. If I ignore the message, I can carry on editing the page and even save it. Therefore, I think if Skuid checked multiple times that the session was invalid and only warned after, say, 3 times, I wonder if this could be a temporary fix to the problem?
Photo of Megan Minahan

Megan Minahan

  • 726 Points 500 badge 2x thumb
Our org just started receiving this error in our pop ups as well
Photo of Kyle Mathis

Kyle Mathis

  • 576 Points 500 badge 2x thumb
the "error parsing json response..." is also what we're getting. 
Photo of Rich Slack

Rich Slack

  • 4,134 Points 4k badge 2x thumb
Us too
Photo of Sarah Hughes

Sarah Hughes

  • 454 Points 250 badge 2x thumb
We have been having the same issue for the last week, with only 5 known users out of 97. I cannot get the error to replicate for me, but I do have screenshots sent from my users. We have asked a series of questions and know that they are all using Chrome, though some went and tried IE after multiple errors, and the time out is happening within seconds sometimes. I passed on Gary's info about just ignoring it, so I will see if that works for them.
Photo of Megan Minahan

Megan Minahan

  • 726 Points 500 badge 2x thumb
Any update on this?
Photo of Gary

Gary

  • 1,518 Points 1k badge 2x thumb
I was going to post yesterday that I thought the problem had gone away, but then I did have a few issues that looked like the same problem. However, I have so many tabs open (and the security rules in the org are fairly strict) that they may have been time outs.

Is it worth the people experiencing this stating which pods we are on? I work mainly in CS81, and it's where I've seen the issue, but like I say, in the last couple of days, the problem may have gone away.
Photo of Tanzir Riad

Tanzir Riad

  • 414 Points 250 badge 2x thumb
I am also having the same issue on a skuid page. I believe its happening when the page/master page has enabled the "Enable Page Caching". When I enable it I get this error. here is the use case:

Enable the page Caching
log in as a user to hit the page (no error pops up)
Do any tasks and log out
Log back again to hit the page (Error pop up occurs)

in Salesforce, The session is 8 hours and works fine.
Photo of Bill McCullough

Bill McCullough, Champion

  • 12,436 Points 10k badge 2x thumb
Same here...we are not using page caching.
Photo of Kyle Mathis

Kyle Mathis

  • 576 Points 500 badge 2x thumb
We are not using page caching where most of these errors occur. However, there are several page includes involved on pages where this seems to be happening. Not sure if it is related. 
Photo of Karen Waldschmitt

Karen Waldschmitt, Official Rep

  • 8,220 Points 5k badge 2x thumb
Tanzir~

Thanks for narrowing it down to that for your situation. Following your steps, I am able to reproduce the issue by. However, once the error message goes away, I am able to work on the page and save any changes. Is this what you are seeing as well? 

Thanks!
Karen
Photo of Tanzir Riad

Tanzir Riad

  • 414 Points 250 badge 2x thumb
Karen,
Yes that is the case. once user cancel the error msg they are able to work on the page. but its confusing to user and getting complains why its happening each time. If you have a solution it would be a great relief.

Thanks,

Tanzir 
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,004 Points 20k badge 2x thumb
Tanzir, this behavior is expected with Page Caching. Page Caching is recommended for users building Skuid Pages that are shown on Force.com Sites, where there is no authentication involved, but it is currently not recommended to use Page Caching within an authenticated environment (e.g. anywhere other than on Force.com Sites) because the entire you will have stale session information cached. 

The behavior is NOT expected when Page Caching is disabled, and we are continuing to investigate on our own as well as in conjunction with Salesforce Support.
Photo of Ryan Denis

Ryan Denis

  • 542 Points 500 badge 2x thumb
This reply was created from a merged topic originally titled Strange errors about users not being logged in....

Anyone seen errors like this before? I have gotten these from users only recently but cannot recreate it. 

Photo of John Watson

John Watson

  • 584 Points 500 badge 2x thumb
I'm not sure why this was merged. The issue in this thread is a javascript popup, not a red error message.
Photo of Sarah Hughes

Sarah Hughes

  • 454 Points 250 badge 2x thumb
John, its actually both for us. We are getting the Javascript popup AND the error parsing error and I think several other folks are, too. It is all related.
Photo of John Watson

John Watson

  • 584 Points 500 badge 2x thumb
I was able to confirm that too. I reproduced the issue again and hit cancel to get the red message.
Photo of Sarah Hughes

Sarah Hughes

  • 454 Points 250 badge 2x thumb
As of today, some of our users that were consistently getting this error are not, but new users are reporting that it is happening to them. One user reported they canceled the error, but it continued to pop up repeatedly until they got frustrated and closed the page. Any update from SalesForce on what is happening?
Photo of Karen Waldschmitt

Karen Waldschmitt, Official Rep

  • 8,220 Points 5k badge 2x thumb
Hi Community~

Sorry for the frustration this is causing many of you :( Thanks for your patience in bearing with us, Salesforce is continuing their investigation.

Hoping to get this resolved soon ...
Karen
Photo of Bill McCullough

Bill McCullough, Champion

  • 12,436 Points 10k badge 2x thumb
Karen,

Anything new from Salesforce on this?

Thanks,

Bill
Photo of Karen Waldschmitt

Karen Waldschmitt, Official Rep

  • 8,220 Points 5k badge 2x thumb
Hi again~

Sorry, Salesforce is still working on it ... 

Thanks for your patience with this!!!
Karen