Skuid pages redirecting to Salesforce1 on iPad

  • 5
  • Problem
  • Updated 4 years ago
  • Solved
We're pretty new to Skuid and developing some functionality for a pilot. We've hit a problem where when accessing Salesforce with an iPad using the browser, if you open up a Skuid page, it brings you to Salesforce1. Is there a way to prevent this from happening as we haven't rolled out Salesforce1 to our users yet.
Photo of Carlo Inting

Carlo Inting

  • 112 Points 100 badge 2x thumb

Posted 4 years ago

  • 5
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
I'm pretty sure that you have the "Enable the Salesforce1 mobile browser app" setting turned on.   Look in your Salesforce Setup at "Mobile Administration --> Salesforce1 --> Settings. 

In our org this is how it looks,  and when we log in on the browser using an iPad we get the standard salesforce app view (including the skuid pages)

Photo of Jsun Pe

Jsun Pe

  • 230 Points 100 badge 2x thumb
Hello there,

I work with Carlo - we have made sure that this tickbox is not ticked yet it still redirects to Salesforce1.

Is it because Skuid automatically assumes that if it is a mobile device it redirects to SF1?

Cheers,
Jsun
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
Try this --- in the Visualforce Pages you are using for overrides to send users to Skuid, make sure that the "Available for Salesforce mobile apps" checkbox is checked.
Photo of Chandra V

Chandra V, Champion

  • 6,966 Points 5k badge 2x thumb
Same problem here, and I tried the VF page overrides checkbox also.  For us, when we are on our Account skuid page and a user clicks on a contact link, it directs the to SF1 - but only to the chatter feed, not even the Contact record.
Photo of Rich Slack

Rich Slack

  • 4,134 Points 4k badge 2x thumb
I get the same behavior on view/detail pages but I don't get the behavior on tab pages. I use Google Chrome on the ipad. Once I login I click the options button on the chrome browser and select "request desktop site" from the Chrome menu. For the rest of the session I never get redirected to Salesforce1 app regardless of which pages I view.
Here is a pic of Chrome:
>


If you are using IOS8 on the Ipad this works in Safari now too. Login to Salesforce then click in the address bar. Once you click in the address bar the favorites panel drops down from the addressbar. Pull it down a little farther with your finger and you will see a "Request Desktop Site" link. Click it and you won't have any more problems the rest of the session.

Here is a pic of Safari IOS8:


I know this isn't a permanent fix, but it is a great workaround that is quick and easy that can get you by. It works great and no permanent changes have to be made to salesforce or the ipad.
(Edited)
Photo of Jsun Pe

Jsun Pe

  • 230 Points 100 badge 2x thumb
Thanks for all your comments so far.

In further testing, we have confirmed the following:
  • The checkbox suggested by Zach sort of worked slightly on some of the links;
  • However, when clicking on a "REFERENCE" type link (in our case, it is a table displaying a column of reference link for a lookup field), it behaves in one of two ways based on the conditions below:
  • If SF1 is installed on iPad, it tries to open SF1, but to something totally random (based on what was setup in the SF1 app on that iPad);
  • If SF1 is NOT installed on iPad, something weird occurs - firstly safari browser does a popup saying the page cannot be opened (!), then when clicking ok, the page then redirects and loads the actual page up in the browser correctly (!!)
Rich - thanks for your advice, it does work however it is only temporary, everytime the user opens a new tab / reloads the browser they need to do it again, it is not ideal...
Photo of Chandra V

Chandra V, Champion

  • 6,966 Points 5k badge 2x thumb
Came across this SF known issue today: https://success.salesforce.com/issues...
Photo of Jsun Pe

Jsun Pe

  • 230 Points 100 badge 2x thumb
Mmmm - this is interesting. I will be keeping a close eye on that. Thanks Chandra :)
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Thanks Chandra.  Its always good to hear that Salesforce is aware of a problem.  Hopefully it will get fixed. 

Jsun - can you confirm that if your users to not have the Salesforce1 app installed on thier devices - their experience is what you expect?  Does the wierd behavior you report above still occur? 
Photo of Jsun Pe

Jsun Pe

  • 230 Points 100 badge 2x thumb
This is now working as expected after the salesforce bug is resolved.
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Thanks for letting us know the Salesforce bug has been resolved.