Skuid page content not rendering when included in component or Lightning Page. /resource/SkuidCustomSnippets not found.

  • 1
  • Problem
  • Updated 1 year ago
  • In Progress
  • (Edited)
Scene: 

1. Skuid page, with content. Preview looks great! Everything loads. 
2. Visualforce page, rendering Skuid page as redirect.  Works great!  Everything loads. 
3. Lightning component, rendering the Skuid page through skuid:page.  Page loads. A div is rendered with the class skuidPage.  But, no Skuid content is rendered. Blank page. 


I've served the lightning component within my app as a standalone Lightning Tab, within a Lightning Page App, and within a standalone .app Lighting App.  Same result.  

Upon inspection, the /resource/SkuidCustomSnippets is not found.  404 on the get request.   This is the only indication of an issue through dev tools... 




I have deployed a custom domain.  Other custom components are working fine. 

What am I missing? How should I proceed?  This is a bit of a showstopper. 
Photo of Phil Ensminger

Phil Ensminger

  • 174 Points 100 badge 2x thumb
  • confused, stumped

Posted 1 year ago

  • 1
Photo of Phil Ensminger

Phil Ensminger

  • 174 Points 100 badge 2x thumb
Solved the missing static resource.  That was my fault. 

But now, the page will load but without any of my custom static resources _that are there_ OR many of the Skuid resources. 
(Edited)
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,200 Points 5k badge 2x thumb
Phil,

What version of Skuid are you on?
What machine and browser are you using?
Just to be clear, are you using the standard Skuid page Lightning component or including Skuid through a custom Lightning component or Lightning component bundle?
Have you made sure to generate page support files for the Skuid page that you'd like to include in Lightning?