skuid license for force.com site guest user

  • 1
  • Question
  • Updated 6 months ago
  • Answered
I'm trying to follow the steps in the Docs for force.com sites: https://docs.skuid.com/latest/en/skuid/deploy/salesforce/visualforce/force-com-site.html

However, when I get to Step 4: Edit Public Access Settings for your new Site, the interface doesn't look anything like what's in the docs.  The profile interface I'm getting is below. So, I can't figure out how to assign a skuid license to the guest user. 
Help?

Photo of Matt Sones

Matt Sones, Champion

  • 31,478 Points 20k badge 2x thumb

Posted 11 months ago

  • 1
Photo of Matt Sones

Matt Sones, Champion

  • 31,478 Points 20k badge 2x thumb
Ah, I was able to get to the user through the "View Users" button, and I can assign the page viewer permission set, but I can't assign a skuid license under managed packages? I'm on a developer edition.
Photo of Matt Sones

Matt Sones, Champion

  • 31,478 Points 20k badge 2x thumb
Skuid doesn't show up in the list of managed packages for the guest user:
Photo of Chandra V

Chandra V, Champion

  • 6,966 Points 5k badge 2x thumb
I did a POC on this a long time ago, and remember having the same problem.  What I recall, is you have to modify your user through the Site itself.  So, go to your Site, click View Public Access Settings and you should be able to get to it from there.
Photo of David Forder

David Forder

  • 2,064 Points 2k badge 2x thumb
If that isn't it let me know. I have set up quite a few public sites before using skuid but it was some time ago. I will video the setup steps and send if needed
Photo of Matt Sones

Matt Sones, Champion

  • 31,478 Points 20k badge 2x thumb
Thanks, Chandra and David. I was able to assign managed package licenses today. Not sure what I missed yesterday.
Photo of Steve Rubin

Steve Rubin

  • 60 Points
OK,  I'm completely lost here with the suggestions (though very appreciative of the help).  It's frustrating that the documentation after 5 months (when this was first reported) still does not match what's in the system. 

@ChandraV,  thanks for your help. I'm not sure I follow what  you were saying. I see what looks like a SKUID type of user for the site but not sure how I connect the object together (in my case a contact object).  Any help is appreciated.