Skuid getting stuck on Saving

  • 1
  • Question
  • Updated 1 year ago
  • In Progress
One of my Salesforce customers is having issues with Skuid getting stuck on "Saving" There is no error message. Any ideas how to troubleshoot this problem?
Photo of Teri Shipp

Teri Shipp

  • 80 Points 75 badge 2x thumb

Posted 1 year ago

  • 1
Photo of Skuidward Tentacles (Raymond)

Skuidward Tentacles (Raymond), Champion

  • 17,224 Points 10k badge 2x thumb
In chrome, if you right click the screen, you will see "Inspect" as an option. One of the tabs will be "console". You can check for errors there.
If saving a model using actions, you have the option on the save action to create an onscreen error if the model cannot save.
Photo of Mark DeSimone

Mark DeSimone, Official Rep

  • 11,040 Points 10k badge 2x thumb
Teri, I'd recommend adding an on-error action for the Save button involved in this issue. By clicking on the exclamation point button (see screenshot below), you can add an action that will occur if there's an error during the save process. This is usually set up to show an error message of your choice, like, "There was an error saving your work." It can be set to show for a number of seconds, then disappear and unblock the UI. This may also unblock the already-blocked UI for the user, and helpfully inform them what happened.

Photo of Janick

Janick

  • 916 Points 500 badge 2x thumb
In the inspection console Raymond mentioned, there is a network tab on which you can see what step takes how long and which step it is that does not proceed.

This can help troubleshooting a lot.

Janick
Photo of Teri Shipp

Teri Shipp

  • 80 Points 75 badge 2x thumb
Thank you for all the help.  It looks like it can't find the logo.  How do I fix that or get rid of the logo?  Screen shot of console:
Photo of Mark DeSimone

Mark DeSimone, Official Rep

  • 11,040 Points 10k badge 2x thumb
Hi Teri, the logo180.png load error comes up often from Salesforce; it's actually harmless and wouldn't be causing the issues you're seeing. Are you able to show the whole console error including the first lines (above what's in the screenshot)? If you could also show the action sequence you have on this save button, that will help too.