Skuid community permissions/license issue

  • 2
  • Question
  • Updated 3 years ago
So I am setting up a community after watching the great tutorial found here: https://community.skuidify.com/skuid/topics/deep_dive_using_skuid_with_salesforce_communities and I'm running into some issues. At one point in the video (around 14:50 - 16:50) Ben is running into the same issues as me! The only problem is that I can't seem to be able to fix it as elegantly as him. I am working in our Testing sandbox, and I have created a permission set as a clone of the standard "Partner Community User". I added all of the skuid apex classes and VF pages to this permission set, as well as the custom objects I would like the users to be able to access. I am getting the following error everytime I hit a skuid redirect:



The way Ben fixed this was by adding a skuid license to the user, however when I go to the installed packages page I don't have a "Manage Licenses" button...



Is this because I am in Testing? Does that mean that it's not possible to test a community out of a sandbox with Skuid? Any help would be appreciated.
Photo of Moshe Karmel

Moshe Karmel, Champion

  • 8,646 Points 5k badge 2x thumb
  • confused by permissions

Posted 4 years ago

  • 2
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
In Sandbox you probably have a Site license to Skuid, so the "Manage Licenses" side of things can't be tested the same way.

Here's what I'd run through. Make sure that your Community Profile has access to:

1. Visualforce override Page(s) which are running Skuid 
2. Read access to the Skuid Page, Page Assignment, and File objects (read/write on File), and any fields / objects that you are showing in the pages you are showing.
3. Make sure that the Skuid Page object has sharing setting of "Public Read Only".
Photo of Moshe Karmel

Moshe Karmel, Champion

  • 8,646 Points 5k badge 2x thumb
Thanks for the reply Zach, I think I'm good on number 1, as far as number 2, I gave the access to Page, Page Assignment and File, but when you say"any fields / objects that you are showing in the pages you are showing." does that mean every object that is referenced by a model? (that may be an issue because there is a 10 custom object limit on community users). About number 3, I checked on the Page custom object in the org and I don't see a "Sharing Setting" field, where can I set the sharing settings? Thanks.
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Re #3 - look in setup for Security Controls -- Sharing Settings.   All objects in your org are listed there. 
Photo of Moshe Karmel

Moshe Karmel, Champion

  • 8,646 Points 5k badge 2x thumb
Thanks guys, I think it was the fact that some of the models from my page referenced objects that the user did not have access to. To this guys point : https://success.salesforce.com/ideaView?id=08730000000krKtAAI that isn't really enough to work with... but I got some things to work! I still have a lot of errors in the console though (89 to be exact) is that from the page trying to load stuff that it can't?

Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
To fix the Internal Server Error issue, try removing the "Tab to Override" property from your Skuid page, just set it to empty.
Photo of Moshe Karmel

Moshe Karmel, Champion

  • 8,646 Points 5k badge 2x thumb
Thanks Zach but I'm still seeing a lot of red down there, like this stuff:
I also clicked a button that runs a snippet and there we're a whole bunch of those POST errors. Do users need certain permissions to be able to run snippets, or do they just need the fields that are affected by the snippet? (Btw thanks for the help I find that you guys are way more knowledgeable than the Salesforce people/docs :) )
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
Okay, I'm guessing you're showing Picklist fields on this page that are RecordType-dependent, or have Controlling Picklist values. For this to work, your Community users will need to have the API Enabled permission on their Profile.
Photo of Moshe Karmel

Moshe Karmel, Champion

  • 8,646 Points 5k badge 2x thumb
Hey Zach I wanted to bring up this issue again, I never got it working completely. The idea to get rid of the "tab to override" field helped. That took it down from around 35 console errors to only 15ish. But I still keep getting a lot of POST and GET errors that look like this.



What do you mean by setting API Enabled on the profile? I don't see a field with that name available, is that a skuid managed package field?
Photo of Moshe Karmel

Moshe Karmel, Champion

  • 8,646 Points 5k badge 2x thumb
Along those lines if I try using a page include in my community page I keep getting the following error and the include portion wont load:

 GET https://testing-prebroker.cs15.force.com/brokersapex/include?id=a3Ze0000000NllLEAS&isinclude=tru... 503 (Service Unavailable)jquery.min.js:4 

One theory that I have is that the url is wrong because there should be a "/" between "brokers" and "apex". "brokers" is the tab name in my community instance. Is there a problem with page includes in communities?
Photo of Michael Tubbs

Michael Tubbs

  • 154 Points 100 badge 2x thumb
Bump. API enabled and removing tab to override did not solve the same errors in my customer portal. 
I'm not sure if this causes any performance problems, but if so Moshe and I can't be the only users that could benefits from a solution to this. Thanks!