skuid CLI - skuid pull

  • 1
  • Question
  • Updated 2 months ago
  • Answered
How to skuid-pull a specific page?

According to the CLI documentation:

Data management:

  • --dir: (string) The input/output directory where files are retrieved and stored to ordeployed from.
    • Abbreviated form: -d
  • --module: (string) Skuid on Salesforce only. One or more Skuid page modules, separated by commas, to deploy or retrieve.
    • Abbreviated form: -m
  • --page: (string) Skuid on Salesforce only. One or more Skuid pages, listed by page name and separated by commas, to retrieve to the local file system.
    • Abbreviated form: -n

Could you provide an example command to pull a specific page? I tried
--module Download --page Download-TestContact

This works: TestContact is the only page in this module.

--module Download

Photo of jili@heidrick.com

jili@heidrick.com

  • 2,032 Points 2k badge 2x thumb

Posted 3 months ago

  • 1
Photo of Matthew Leahy

Matthew Leahy, Employee

  • 592 Points 500 badge 2x thumb
Hello,

Try the following to pull a single page:

skuid pull --host https://<Domain>.my.salesforce.com -n <PageName> -v

Let me know your results.

Thanks,
Matt
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
Jill, what Skuid release do you have installed in your org? The ability to pull specific pages by name may not be available in the release of Skuid that is in your org. 
Photo of jili@heidrick.com

jili@heidrick.com

  • 2,032 Points 2k badge 2x thumb
We are still on Rockaway. The skuid REST API in Rockaway does not support the new -n flag?
Photo of J.

J., Official Rep

  • 7,470 Points 5k badge 2x thumb
That is correct. The single page functionality was added in Millau (11.2.0). Your Salesforce instance will need to be updated to at least this version of Skuid in order for this functionality to work.
(Edited)
Photo of jili@heidrick.com

jili@heidrick.com

  • 2,032 Points 2k badge 2x thumb
Thanks very much! We are going for the Millau upgrade soon!
Photo of jili@heidrick.com

jili@heidrick.com

  • 2,032 Points 2k badge 2x thumb
CLI is working correctly against Millau.

I'm also evaluating https://github.com/skuid/skuid-grunt

  • options.page: [String or Array| Required] The Page(s) you want to pull down (Requires Skuid Version 11.2 or higher).

I tried this again a Millau 11.2.8. It is still querying against the module name in the API calls to Salesforce and downloading the page with empty module name.
  var millauOptions = {
    'clientId': '',
    'clientSecret': '',
    'username': '',
    'password': '',
  'nforceOptions': {
      'environment': 'sandbox',
    'loginUri': 'test.salesforce.com'
}
  };

    'skuid-pull':{
      'options': millauOptions,
      'devpro01':{
        'options':{
          'dest': 'skuidpages/',
          'page':['SFHeaderContactDetail'],
        }
      }
    }
Is options.page supported in the grunt version as the documentation says?
(Edited)