Skuid Brroklyn Isssue (I assume): Unable to see the Drop down when Clicking the Gear Icon shown below

  • 1
  • Question
  • Updated 2 years ago
  • Acknowledged
Hello Community,

I have Cases Skuid page with Queue Component on it. this component shows all the cases listed in the queue. We also have a filter within the queue to filter the cases by status, Cases by user.
The following is the issue i am currently facing.


The Filter section is hidden behind the case queue for some reason. Everything was fine till yesterday.

I updated to Skuid Brooklyn Iteration 4 today morning and an hour after that i got this issue.

Also I copy pasted the XML of this page in our sandbox(which is on Skuid Rockaway Editon) and the page is perfectly fine.
I don't understand why we are facing this issue only in Production. Does this issue has something to do with the Skuid update that i made.

Can anyone help me out with this issue?
Photo of Avinash

Avinash

  • 1,726 Points 1k badge 2x thumb

Posted 2 years ago

  • 1
Photo of Khamla Phimmachack

Khamla Phimmachack, Official Rep

  • 1,536 Points 1k badge 2x thumb
Hi Avinash,

I was not able to reproduce the problem that you have using filters in the queue component. If you are still experiencing this issue:

- Are you still using Iteration 4?
- Are you experiencing the same behavior in different browsers? (i.e. chrome vs. firefox vs. IE)
- Is there any custom code involved on this page?
- Do you see any Javascript errors in the developer console?

Thanks
Photo of Avinash

Avinash

  • 1,726 Points 1k badge 2x thumb
All the themes are up to date. But still I see the issue.
Photo of Stephen Sells

Stephen Sells, Official Rep

  • 16,856 Points 10k badge 2x thumb
Is there any particular reason you upgraded your production environment first instead of the sandbox. Skuid recommends upgrading the sandbox first. Because there is no regression allowed in Salesforce, you might want to upgrade your sandbox to match the production environment.

Unfortunately, I am unable to see the problem using your code. I'm beginning to wonder if it is something unique to your page. Are other people using your skuid experiencing the issue or is it specific only to a few?

Could you clear out your cache and see if that helps?
Photo of Avinash

Avinash

  • 1,726 Points 1k badge 2x thumb
There is no particular reason on why I updated the Production first. I'll update my sandbox. I created a Sample blank page on case object in my Sandbox (BTW I updated my sandbox to today's release Brooklyn Update 1 - Iteration 3 (9.5.3)). I added queue component and then created a queue filter  but that is also having the same issue like the one in Production.

This is the page I have no fields no JavaScript, no CSS. But still the queue filter is having issue.  
The XML of the page is below.
\<skuidpage unsavedchangeswarning="yes" personalizationmode="server" showsidebar="false" useviewportmeta="true" showheader="false">
    <models>
        <model id="case" limit="100" query="true" createrowifnonefound="false" datasource="salesforce" type="" orderby="CaseNumber DESC" sobject="Case">
            <fields/>
            <conditions>
                <condition type="fieldvalue" value="" enclosevalueinquotes="true" field="Status" state="filterableoff" inactive="true" name="Status"/>
                <condition type="userinfo" value="" field="OwnerId" operator="=" enclosevalueinquotes="true" userinfotype="userid" state="filterableoff" inactive="true" name="Owner"/>
                <condition type="multiple" value="" field="Owner.Name" operator="in" enclosevalueinquotes="true" state="filterableon" inactive="false" name="Helpdesk">
                    <values>
                        <value>Jason Coorsh</value>
                        <value>Helpdesk</value>
                        <value>Sergey Yun</value>
                        <value>Avinash Babu</value>
                        <value>Marcus Danko</value>
                        <value>Kenny Hollis</value>
                    </values>
                </condition>
                <condition type="multiple" value="" field="IsClosed" operator="in" enclosevalueinquotes="false" state="filterableoff" inactive="true" name="Closed">
                    <values/>
                </condition>
            </conditions>
            <actions/>
        </model>
    </models>
    <components>
        <panelset type="standard" uniqueid="sk-3tGrUc-108" scroll="">
            <panels>
                <panel type="left" width="225px">
                    <components>
                        <queue model="case" tagrendertype="template" searchbox="true" tokenizesearch="true" showsearchbydefault="true" uniqueid="sk-3tGvMc-114">
                            <rendertemplate>{{Name}}</rendertemplate>
                            <interactions>
                                <interaction type="tap">
                                    <action type="updateIncludePanel" querystring="id={{Id}}"/>
                                </interaction>
                            </interactions>
                            <filters>
                                <filter type="select" filteroffoptionlabel="Test Filter" createfilteroffoption="true" affectcookies="true" autocompthreshold="25" conditionsource="manual" labelmode="no">
                                    <sources>
                                        <source type="manual" effectsbehavior="justdefault">
                                            <options>
                                                <option label="All Helpdesk Cases" type="complex">
                                                    <effects>
                                                        <effect action="activate" value="" condition="Helpdesk"/>
                                                    </effects>
                                                </option>
                                            </options>
                                        </source>
                                        <source type="manual" effectsbehavior="justdefault">
                                            <options>
                                                <option label="All My Cases" type="complex">
                                                    <effects>
                                                        <effect action="deactivate" value="" condition="Helpdesk"/>
                                                        <effect action="activate" value="" condition="Owner"/>
                                                        <effect action="deactivate" value="" condition="Closed"/>
                                                    </effects>
                                                </option>
                                            </options>
                                        </source>
                                    </sources>
                                </filter>
                            </filters>
                        </queue>
                    </components>
                </panel>
                <panel>
                    <components/>
                </panel>
            </panels>
        </panelset>
    </components>
    <resources>
        <labels/>
        <javascript/>
        <css/>
    </resources>
    <styles>
        <styleitem type="background" bgtype="none"/>
    </styles>
</skuidpage>


I have several table filters in my sandbox and Production. Everyone of them is working perfectly. But those filters which are in Queue component are not working.
 There are three similar Queue pages and all three are not working.
Photo of Stephen Sells

Stephen Sells, Official Rep

  • 16,856 Points 10k badge 2x thumb
Did you delete your cache?
Photo of Avinash

Avinash

  • 1,726 Points 1k badge 2x thumb
Yes I did delete cache and still no luck.