Sharing Skuid Pages with other users/profiles

  • 1
  • Problem
  • Updated 9 months ago
  • Solved
I have created a custom object and built a skuid page around that. I am unable to give access to the Skuid page for few users with the same profile. Below is the error message.

You've been INKED! (Something went wrong)
We were unable to find a Skuid Page named (Skuid page name). The Page is either inaccessible or does not exist. If you believe you should be able to view this Skuid Page, ask your System Administrator to check the Sharing Model for the Page object to ensure that you have access to this Skuid Page.

I followed the below link and added users to the Skuid Page Buidler and Skuid Page Viewer Permission sets. But still have the above error.

http://help.skuidify.com/m/getting-started/l/102645-let-other-users-access-skuid#In-Salesforce-Setup...
Photo of Raj

Raj

  • 150 Points 100 badge 2x thumb

Posted 3 years ago

  • 1
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
Go to Setup > Sharing Settings and check the Organization-wide Default Sharing Settings for the Skuid Page object --- make sure that the Page object's Sharing default is set to Public Read Only and not Private.
Photo of Raj

Raj

  • 150 Points 100 badge 2x thumb
I tried both Public read/Write and Public read only. Still no luck!
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
Are you using Page Assignments? Make sure that the Page Assignment org wide default is Public Read Only as well. 

What does your Visualforce Page override look like? 
Photo of Raj

Raj

  • 150 Points 100 badge 2x thumb

Nope not using any page assignments.

apex:page showHeader="true" sidebar="false">
<skuid:page page="BoardObject"/>
</apex:page>
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
Can you check whether these users are able to access the page using the following URL:

/apex/skuid__UI?page=BoardObject
Photo of Raj

Raj

  • 150 Points 100 badge 2x thumb
Nope. Same error!
Photo of Raj

Raj

  • 150 Points 100 badge 2x thumb
I found the issue. Just like security on vf pages, Share button on the App builder helped me expose the skuid page to all users.
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
Aha, so your were using Skuid within Lightning App Builder, and it has its own Sharing settings? Good to know.
Photo of Raj

Raj

  • 150 Points 100 badge 2x thumb


I saw this option in both Lightning and Visual Force. I am building pages in visual force!

Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
Oh okay - that's weird that you'd need to manually share the page with all users. Changing your Organization Wide Defaults in Sharing Settings to Public Read Only / Public Read Write should have made it possible for others to read / edit all pages, respectively.
Photo of Raj

Raj

  • 150 Points 100 badge 2x thumb
Looks like Skuid Online documentations need to be updated as per their new enhancements. I randomly saw the share button which seems to be worked out. I spent at least 5 hours just around this sharing issue.
Photo of Zach McElrath

Zach McElrath, Employee

  • 49,056 Points 20k badge 2x thumb
Raj, we're really bummed that it took so long to resolve this issue --- we're trying to understand what the cause of the problem here was, because clicking on the Share button really should not have been necessary. Do you have an "External Sharing Model" enabled in your org? With separate Org Wide Defaults for internal and external users? 
Photo of Raj

Raj

  • 150 Points 100 badge 2x thumb

All objects in our org are public read/Write. Nope  "External Sharing Model"  is not enabled in our org.

Photo of ashish

ashish

  • 80 Points 75 badge 2x thumb
Hi I am also facing the same issue Please give me some solution
(Edited)