Search Component Transparency Glitch

  • 1
  • Problem
  • Updated 1 year ago
  • In Progress
I've just now noticed a visual glitch when using the search component outside of my custom header. The results appear to have a transparent background but the theme setting is set to white. I've attached screenshots of the current behavior, expected behavior, and theme settings. 

Issue was apparent in both 9.5.4 when I noticed it, and in 9.5.5 on which i'm currently running on. 

Current:

Expected

Theme Settings
Photo of Erik Wahlberg

Erik Wahlberg

  • 2,156 Points 2k badge 2x thumb

Posted 2 years ago

  • 1
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,200 Points 5k badge 2x thumb
Erik,

You've probably checked this, but can you update your themes? I'm not positive that upgrading will fix your problem, but I can't reproduce your problem on 9.5.7. I'm able to set the background of the results to white and they show that way.
Photo of mB Roman Melnik

mB Roman Melnik

  • 2,802 Points 2k badge 2x thumb
@Erik, I believe there's an easy fix for this. As we had the same problem.



@Amy, if it helps. We first noticed the same glitch back in April. I made a task for myself with a date-stamp of "Monday, April 3, 2017" to fix this issue.

So that means it was present in 9.5.3 (or earlier), as 9.5.4 was released April 4th. The fact that this transparency issue cropped up suddenly across multiple orgs makes me think that between Skuid releases, the css inheritance rule that I mention at 0:35secs was changed.
(Edited)
Photo of Amy Dewaal

Amy Dewaal, Official Rep

  • 8,200 Points 5k badge 2x thumb
Erik,

Per Roman's video, do you know if you purposely or accidentally have the Search Result Item backgrounds (even and odd) set to transparent? I'm still having difficulty nailing this down since it seems like as long as I have the Search Results background set to white (like you do in your screenshot) the background of all the results is white. Also, in the theme builder can you click on the name of the color (white) for the Search Results background and choose the color again and see if your save enables? When I was trying to investigate this I noticed that sometimes my color options didn't actually take, even when it looked like they were set.