Save Button not rendering correctly on Salesforce1 app

  • 1
  • Problem
  • Updated 3 years ago
  • In Progress
Having an issue with the Save button. 

When the Save button is pressed, an opportunity record is created, however, the page gets directed to a standard webpage within Salesforce1 (see second screenshot).

Not sure if my ON-TAP ACTIONS are correct: 


Photo of ns

ns

  • 1,822 Points 1k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Karen Waldschmitt

Karen Waldschmitt, Official Rep

  • 8,240 Points 5k badge 2x thumb
Nick~

It looks like the problem is with your Go To URL. Preview the Skuid page you want this page to redirect to on tap. Copy the URL from that page and keep the part from /apex on. For example, if I want to redirect to a page called OpportunityDetail, this is what I would have in the Go To URL /apex/skuid__ui?page=OpportunityDetail.

Thanks!
Karen
Photo of ns

ns

  • 1,822 Points 1k badge 2x thumb
Hi Karen,

This didn't work...
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
One more thing.  You need to wrap your Id field in {{{Triple Braces}}}.   Somehow your url is breaking and then just going to the Salesforce home page,  and I suspect that because you are putting your id in double braces - skuid is attempting to add some additional code to the merge which is making the URL break...
Photo of ns

ns

  • 1,822 Points 1k badge 2x thumb

Hi Rob,

Adding the triple braces didn't work either. Here is what my URL redirect looks like in Skuid:
https://xxxxxxx.mysalesforce.com/{{{Id}}}

Our old URL of https://xxxxxxxx.mysalesforce.com/{{Id}} was working up until a couple of days ago when I had inserted 3 fields into the Deck, but removed the 3 fields. This is when the SAVE function broke. Nothing else was changed.


Here's what the URL looks like when I access the Opportunity record in a web browser:  

Photo of ns

ns

  • 1,822 Points 1k badge 2x thumb
This reply was created from a merged topic originally titled Save Button not rendering correctly on Salesforce1 app URL DIRECT?.

Having an issue with the Save button. 

When the Save button is pressed, an opportunity record is created, however, the page gets directed to a standard webpage within Salesforce1 (see second screenshot).

Not sure if my ON-TAP ACTIONS are correct: 






Adding the triple braces didn't work either. Here is what my URL redirect looks like in Skuid:  https://xxxxxxx.mysalesforce.com/{{{Id}}}

Our old URL of https://xxxxxxxx.mysalesforce.com/{{Id}} was working up until a couple of days ago when I had inserted 3 fields into the Deck, but removed the 3 fields. This is when the SAVE function broke. Nothing else was changed.



Here's what the URL looks like when I access the Opportunity record in a web browser:  
Photo of ploodeed

ploodeed

  • 162 Points 100 badge 2x thumb
Any ideas? 
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
Looks to me like you have the opportunity view override set to a visualforce page that has not been enabled for use in the mobile environment. 
Photo of ploodeed

ploodeed

  • 162 Points 100 badge 2x thumb
Hi Rob, 

I do have the "Available for Salesforce mobile apps and Lightning Pages" selected on the visualforce page :(

Would it be best to rebuild my mobile skuid page? 

Thanks!
Photo of ploodeed

ploodeed

  • 162 Points 100 badge 2x thumb
This has been resolved. This issue, however, were from several minor factors. 

1) The "Go To URL" should have been set to:   "http://xxxxxx.mysalesforce.com//{{{$Model.Opportunity.data.0.Id}}}" (Thanks Zach for bringing it up and thank you Rob for walking me through this today)

2) The On-Tap Actions were out of order, and had to be re-arranged (Thank you Rob!)

3) A Page Assignment, applied to Organization Default, had to be created in order for System Admin to view the rendered page after clicking on the Save button (again, thank you Rob!)
Photo of Rob Hatch

Rob Hatch, Official Rep

  • 44,006 Points 20k badge 2x thumb
All good.  Glad we were able to get things working!